aboutsummaryrefslogtreecommitdiffstats
path: root/kde2/po/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kde2/po/Makefile.am')
-rw-r--r--kde2/po/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde2/po/Makefile.am b/kde2/po/Makefile.am
new file mode 100644
index 0000000..4504a98
--- /dev/null
+++ b/kde2/po/Makefile.am
@@ -0,0 +1,24 @@
+
+SUBDIRS = de
+
+APPS = kpsion
+
+merge:
+ @apps='$(APPS)'; \
+ langs='$(SUBDIRS)'; \
+ for cat in $$apps; do \
+ for lang in $$langs; do \
+ if test -r $$lang/$$cat.po; then \
+ echo $$cat; \
+ msgmerge -o $$cat.new $$lang/$$cat.po $$cat.pot; \
+ if test -s $$cat.new && diff $$lang/$$cat.po $$cat.new; then \
+ rm $$cat.new; \
+ else \
+ mv $$cat.new $$lang/$$cat.po ; \
+ fi; \
+ fi ;\
+ done ;\
+ done
+
+messages:
+