aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index def9a41..4298800 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,13 +5,21 @@ EXTRA_DIST = COPYING README TODO INSTALL README.mjg include/*.h* etc/*magic etc/
DISTCLEANFILES = etc/psion
AUTOMAKE_OPTIONS = foreign
+TMPDEST=
#
# remove all intermediate files that can be recreated using
# Makefile.cvs
#
maintainer-clean-local:
rm -f configure aclocal.m4 config.guess config.sub Makefile.in \
- install-sh ltconfig ltmain.sh missing mkinstalldirs
+ install-sh ltconfig ltmain.sh missing mkinstalldirs etc/*.spec
+
+dist-hook:
+ $(MAKE) TMPDEST=$(distdir)/ kdoc specfile
kdoc:
- kdoc -d doc/api -n libplp lib/*.h
+ kdoc -d $(TMPDEST)doc/api -n libplp $(TMPDEST)lib/*.h
+
+specfile:
+ sed -e "s/_VERSION_/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
+ > $(TMPDEST)etc/plptools.spec