aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2000-11-11 16:17:14 +0000
committerFritz Elfert <felfert@to.com>2000-11-11 16:17:14 +0000
commit39a85c943fff6a35ec57b02f67cd38f9550f3c78 (patch)
tree9fe19838c6d65443933158c7cea3cc229af76616 /Makefile.am
parent67b6274d0f8fa796770ebb5201dbfaf2b7c1dd6d (diff)
downloadplptools-39a85c943fff6a35ec57b02f67cd38f9550f3c78.tar.gz
plptools-39a85c943fff6a35ec57b02f67cd38f9550f3c78.tar.bz2
plptools-39a85c943fff6a35ec57b02f67cd38f9550f3c78.zip
Misc. Makefile changes.
Bumped up version.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index def9a41..4298800 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,13 +5,21 @@ EXTRA_DIST = COPYING README TODO INSTALL README.mjg include/*.h* etc/*magic etc/
DISTCLEANFILES = etc/psion
AUTOMAKE_OPTIONS = foreign
+TMPDEST=
#
# remove all intermediate files that can be recreated using
# Makefile.cvs
#
maintainer-clean-local:
rm -f configure aclocal.m4 config.guess config.sub Makefile.in \
- install-sh ltconfig ltmain.sh missing mkinstalldirs
+ install-sh ltconfig ltmain.sh missing mkinstalldirs etc/*.spec
+
+dist-hook:
+ $(MAKE) TMPDEST=$(distdir)/ kdoc specfile
kdoc:
- kdoc -d doc/api -n libplp lib/*.h
+ kdoc -d $(TMPDEST)doc/api -n libplp $(TMPDEST)lib/*.h
+
+specfile:
+ sed -e "s/_VERSION_/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
+ > $(TMPDEST)etc/plptools.spec