aboutsummaryrefslogtreecommitdiffstats
path: root/dist/msys2-mingw/mcode/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'dist/msys2-mingw/mcode/PKGBUILD')
-rw-r--r--dist/msys2-mingw/mcode/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/dist/msys2-mingw/mcode/PKGBUILD b/dist/msys2-mingw/mcode/PKGBUILD
new file mode 100644
index 000000000..591fa6693
--- /dev/null
+++ b/dist/msys2-mingw/mcode/PKGBUILD
@@ -0,0 +1,28 @@
+_realname=ghdl-mcode
+pkgbase=mingw-w64-${_realname}
+pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
+pkgver=ci
+pkgrel=1
+pkgdesc="GHDL: the open-source analyzer, compiler and simulator for VHDL (mcode backend) (mingw-w64)"
+arch=('any')
+#depends=()
+makedepends=("${MINGW_PACKAGE_PREFIX}-gcc" "${MINGW_PACKAGE_PREFIX}-gcc-ada")
+#source=(
+# "ghdl::git://github.com/ghdl/ghdl.git#branch=master"
+#)
+#sha512sums=(
+# 'SKIP'
+#)
+
+build() {
+ mkdir "${srcdir}/builddir"
+ cd "${srcdir}/builddir"
+ ../../../../../configure --prefix=${MINGW_PREFIX} LDFLAGS=-static --enable-libghdl --enable-synth
+ make GNATMAKE="gnatmake -j$(nproc)"
+}
+
+package() {
+ cd "${srcdir}/builddir"
+ mkdir -p "${pkgdir}${MINGW_PREFIX}/lib"
+ make DESTDIR="${pkgdir}" install
+}