aboutsummaryrefslogtreecommitdiffstats
path: root/dist/msys2-mingw/mcode/PKGBUILD
diff options
context:
space:
mode:
author1138-4EB <1138-4EB@users.noreply.github.com>2019-11-21 17:39:24 +0000
committertgingold <tgingold@users.noreply.github.com>2019-11-21 18:39:24 +0100
commite506f77e8f6ddeb3e114a3b7e3ce5f114192d801 (patch)
treed9387c5867ba98c81988591713249915230db9e3 /dist/msys2-mingw/mcode/PKGBUILD
parent03862a4607fd127e6570a3e141a92265a23c2a68 (diff)
downloadghdl-e506f77e8f6ddeb3e114a3b7e3ce5f114192d801.tar.gz
ghdl-e506f77e8f6ddeb3e114a3b7e3ce5f114192d801.tar.bz2
ghdl-e506f77e8f6ddeb3e114a3b7e3ce5f114192d801.zip
Actions: add workflow 'push' (#1016)
* use CC=clang to build C sources on macOS * actions: ensure that shared libs are in the PATH on windows * ci: add GitHub Actions 'push' workflow * ci: fix group labels * dist: add GRAY to ansi_color * ci: use same scripts for GHA and Travis
Diffstat (limited to 'dist/msys2-mingw/mcode/PKGBUILD')
-rw-r--r--dist/msys2-mingw/mcode/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/dist/msys2-mingw/mcode/PKGBUILD b/dist/msys2-mingw/mcode/PKGBUILD
new file mode 100644
index 000000000..591fa6693
--- /dev/null
+++ b/dist/msys2-mingw/mcode/PKGBUILD
@@ -0,0 +1,28 @@
+_realname=ghdl-mcode
+pkgbase=mingw-w64-${_realname}
+pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
+pkgver=ci
+pkgrel=1
+pkgdesc="GHDL: the open-source analyzer, compiler and simulator for VHDL (mcode backend) (mingw-w64)"
+arch=('any')
+#depends=()
+makedepends=("${MINGW_PACKAGE_PREFIX}-gcc" "${MINGW_PACKAGE_PREFIX}-gcc-ada")
+#source=(
+# "ghdl::git://github.com/ghdl/ghdl.git#branch=master"
+#)
+#sha512sums=(
+# 'SKIP'
+#)
+
+build() {
+ mkdir "${srcdir}/builddir"
+ cd "${srcdir}/builddir"
+ ../../../../../configure --prefix=${MINGW_PREFIX} LDFLAGS=-static --enable-libghdl --enable-synth
+ make GNATMAKE="gnatmake -j$(nproc)"
+}
+
+package() {
+ cd "${srcdir}/builddir"
+ mkdir -p "${pkgdir}${MINGW_PREFIX}/lib"
+ make DESTDIR="${pkgdir}" install
+}