aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2019-10-06 14:41:46 +0200
committerGitHub <noreply@github.com>2019-10-06 14:41:46 +0200
commit902ef59d01f45613ce33520159e157697bcc6f9f (patch)
tree53d98b7e623ab1538b6bd53ff158d46e5f6977fc /setup.py
parentc88d3a943109132010a932aca82411a1527d934a (diff)
downloadmitmproxy-902ef59d01f45613ce33520159e157697bcc6f9f.tar.gz
mitmproxy-902ef59d01f45613ce33520159e157697bcc6f9f.tar.bz2
mitmproxy-902ef59d01f45613ce33520159e157697bcc6f9f.zip
Move onboardingapp from tornado to flask (#3661)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3b9e1605..7c5f1eb2 100644
--- a/setup.py
+++ b/setup.py
@@ -66,6 +66,7 @@ setup(
"certifi>=2019.9.11", # no semver here - this should always be on the last release!
"click>=7.0,<8",
"cryptography>=2.1.4,<2.5",
+ "flask>=1.1.1,<1.2",
"h2>=3.0.1,<4",
"hyperframe>=5.1.0,<6",
"kaitaistruct>=0.7,<0.9",
@@ -78,7 +79,7 @@ setup(
"pyperclip>=1.6.0,<1.8",
"ruamel.yaml>=0.16,<0.17",
"sortedcontainers>=2.1.0,<2.2",
- "tornado>=4.3,<5.2",
+ "tornado>=4.3,<7",
"urwid>=2.0.1,<2.1",
"wsproto>=0.14.0,<0.15.0",
"publicsuffix2>=2.20190812,<3",