aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@corte.si>2016-10-17 15:35:09 +1300
committerGitHub <noreply@github.com>2016-10-17 15:35:09 +1300
commit421679a770c811ceeeccace6310dffcbbe6362dd (patch)
tree6bbdcfe54fcce1e41660ca07c9470f42debdec5b /setup.py
parent4918feb7252c76c95d85cd8b2b0334a22aaae274 (diff)
parent8360f70024330eeeb5c53d29e4a05194f872b511 (diff)
downloadmitmproxy-421679a770c811ceeeccace6310dffcbbe6362dd.tar.gz
mitmproxy-421679a770c811ceeeccace6310dffcbbe6362dd.tar.bz2
mitmproxy-421679a770c811ceeeccace6310dffcbbe6362dd.zip
Merge pull request #1613 from cortesi/python3
First-order conversion to Python3-only
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index abc80b33..0c359f1c 100644
--- a/setup.py
+++ b/setup.py
@@ -30,8 +30,6 @@ setup(
"Operating System :: POSIX",
"Operating System :: Microsoft :: Windows",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: CPython",
@@ -93,13 +91,6 @@ setup(
],
':sys_platform != "win32"': [
],
- # Do not use a range operator here: https://bitbucket.org/pypa/setuptools/issues/380
- # Ubuntu Trusty and other still ship with setuptools < 17.1
- ':python_version == "2.7"': [
- "enum34>=1.0.4, <2",
- "ipaddress>=1.0.15, <1.1",
- "typing==3.5.2.2",
- ],
'dev': [
"tox>=2.3, <3",
"mock>=2.0, <2.1",