aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAldo Cortesi <aldo@nullcube.com>2016-10-17 15:15:22 +1300
committerAldo Cortesi <aldo@nullcube.com>2016-10-17 15:18:47 +1300
commit8360f70024330eeeb5c53d29e4a05194f872b511 (patch)
tree6bbdcfe54fcce1e41660ca07c9470f42debdec5b /setup.py
parent4918feb7252c76c95d85cd8b2b0334a22aaae274 (diff)
downloadmitmproxy-8360f70024330eeeb5c53d29e4a05194f872b511.tar.gz
mitmproxy-8360f70024330eeeb5c53d29e4a05194f872b511.tar.bz2
mitmproxy-8360f70024330eeeb5c53d29e4a05194f872b511.zip
First-order conversion to Python3-only
- Zap various occurrences of Python2 in docs and scripts - Remove six from netlib, and some other places where obvious project-wide search and replace works.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index abc80b33..0c359f1c 100644
--- a/setup.py
+++ b/setup.py
@@ -30,8 +30,6 @@ setup(
"Operating System :: POSIX",
"Operating System :: Microsoft :: Windows",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: CPython",
@@ -93,13 +91,6 @@ setup(
],
':sys_platform != "win32"': [
],
- # Do not use a range operator here: https://bitbucket.org/pypa/setuptools/issues/380
- # Ubuntu Trusty and other still ship with setuptools < 17.1
- ':python_version == "2.7"': [
- "enum34>=1.0.4, <2",
- "ipaddress>=1.0.15, <1.1",
- "typing==3.5.2.2",
- ],
'dev': [
"tox>=2.3, <3",
"mock>=2.0, <2.1",