aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 33b3b54e..b134e0a0 100644
--- a/setup.py
+++ b/setup.py
@@ -47,14 +47,14 @@ if sys.version_info < (3, 3):
requirements.append("ipaddress")
if platform.python_implementation() == "PyPy":
- if sys.pypy_version_info < (2, 6):
+ if sys.pypy_version_info < (5, 3):
raise RuntimeError(
- "cryptography 1.0 is not compatible with PyPy < 2.6. Please "
+ "cryptography 1.9 is not compatible with PyPy < 5.3. Please "
"upgrade PyPy to use this library."
)
else:
- requirements.append("cffi>=1.4.1")
- setup_requirements.append("cffi>=1.4.1")
+ requirements.append("cffi>=1.7")
+ setup_requirements.append("cffi>=1.7")
test_requirements = [
"pytest>=2.9.0",