aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2017-05-23 20:31:03 -0700
committerPaul Kehrer <paul.l.kehrer@gmail.com>2017-05-23 20:31:03 -0700
commit6091e11cae1e2ca43709266d0e3ba84ded12ddfc (patch)
tree070abc134d8afff90dcb4a09ed0c659b999a8a1d /setup.py
parent70e8f90b250ba65167943f67cb851495bc7b8add (diff)
downloadcryptography-6091e11cae1e2ca43709266d0e3ba84ded12ddfc.tar.gz
cryptography-6091e11cae1e2ca43709266d0e3ba84ded12ddfc.tar.bz2
cryptography-6091e11cae1e2ca43709266d0e3ba84ded12ddfc.zip
Bump the minimum PyPy/cffi version and simplify as a result (#3585)
* Bump the minimum PyPy/cffi version and simplify as a result * unused imports * grumble, fix
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 33b3b54e..b134e0a0 100644
--- a/setup.py
+++ b/setup.py
@@ -47,14 +47,14 @@ if sys.version_info < (3, 3):
requirements.append("ipaddress")
if platform.python_implementation() == "PyPy":
- if sys.pypy_version_info < (2, 6):
+ if sys.pypy_version_info < (5, 3):
raise RuntimeError(
- "cryptography 1.0 is not compatible with PyPy < 2.6. Please "
+ "cryptography 1.9 is not compatible with PyPy < 5.3. Please "
"upgrade PyPy to use this library."
)
else:
- requirements.append("cffi>=1.4.1")
- setup_requirements.append("cffi>=1.4.1")
+ requirements.append("cffi>=1.7")
+ setup_requirements.append("cffi>=1.7")
test_requirements = [
"pytest>=2.9.0",