aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2018-01-09 00:22:32 -0500
committerGitHub <noreply@github.com>2018-01-09 00:22:32 -0500
commit0e6da4cead72ab739171bbe98570da971c3283b6 (patch)
tree99a678b6b6fe1c8bc76e14287a9b7026c03019b7 /googlemock/CMakeLists.txt
parentcdedd189b22a6578e935256294175b9884e3cf17 (diff)
parente194f52114a181cb3fb420d58d5ae2250207e828 (diff)
downloadgoogletest-0e6da4cead72ab739171bbe98570da971c3283b6.tar.gz
googletest-0e6da4cead72ab739171bbe98570da971c3283b6.tar.bz2
googletest-0e6da4cead72ab739171bbe98570da971c3283b6.zip
Merge branch 'master' into fix-core-dump-shared
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index 7b91a411..bac2e3bf 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -110,8 +110,8 @@ endif()
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gmock INTERFACE "${gmock_SOURCE_DIR}/include")
- target_include_directories(gmock_main INTERFACE "${gmock_SOURCE_DIR}/include")
+ target_include_directories(gmock SYSTEM INTERFACE "${gmock_SOURCE_DIR}/include")
+ target_include_directories(gmock_main SYSTEM INTERFACE "${gmock_SOURCE_DIR}/include")
endif()
########################################################################
@@ -119,11 +119,11 @@ endif()
# Install rules
if(INSTALL_GMOCK)
install(TARGETS gmock gmock_main
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+ install(DIRECTORY "${gmock_SOURCE_DIR}/include/gmock"
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
# configure and install pkgconfig files
configure_file(