aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-12-08 11:12:19 -0500
committerGitHub <noreply@github.com>2017-12-08 11:12:19 -0500
commitcdedd189b22a6578e935256294175b9884e3cf17 (patch)
tree7c14575481ab68972a469cd59c34be1dc5379119 /googlemock/CMakeLists.txt
parent0663ce9024c9b78ddf6eb3fc1ceb45361ed91767 (diff)
parent4d1f930af878dbd929f33088c375175896f4e365 (diff)
downloadgoogletest-cdedd189b22a6578e935256294175b9884e3cf17.tar.gz
googletest-cdedd189b22a6578e935256294175b9884e3cf17.tar.bz2
googletest-cdedd189b22a6578e935256294175b9884e3cf17.zip
Merge branch 'master' into fix-core-dump-shared
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index f7bad8af..7b91a411 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -74,6 +74,8 @@ include_directories("${gmock_SOURCE_DIR}/include"
# <= VS 2010 <= 10 <= 1600 Use Google Tests's own tuple.
# VS 2012 11 1700 std::tr1::tuple + _VARIADIC_MAX=10
# VS 2013 12 1800 std::tr1::tuple
+# VS 2015 14 1900 std::tuple
+# VS 2017 15 >= 1910 std::tuple
if (MSVC AND MSVC_VERSION EQUAL 1700)
add_definitions(/D _VARIADIC_MAX=10)
endif()