aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/AVR/compilers
diff options
context:
space:
mode:
authorutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-06-29 23:03:23 +0000
committerutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-06-29 23:03:23 +0000
commit5eb1ae8cc3f4d2584d31e2d9672162bf8bfc0274 (patch)
treed9d788870f95e67c1a8af1cfcb86bda86d680794 /os/rt/ports/AVR/compilers
parent852f75dabe8c25a01d6becc6291aa8c26dda0cf5 (diff)
downloadChibiOS-5eb1ae8cc3f4d2584d31e2d9672162bf8bfc0274.tar.gz
ChibiOS-5eb1ae8cc3f4d2584d31e2d9672162bf8bfc0274.tar.bz2
ChibiOS-5eb1ae8cc3f4d2584d31e2d9672162bf8bfc0274.zip
Add initial RT-3 AVR port
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@6998 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/rt/ports/AVR/compilers')
-rw-r--r--os/rt/ports/AVR/compilers/GCC/chtypes.h99
-rw-r--r--os/rt/ports/AVR/compilers/GCC/mk/port.mk7
2 files changed, 106 insertions, 0 deletions
diff --git a/os/rt/ports/AVR/compilers/GCC/chtypes.h b/os/rt/ports/AVR/compilers/GCC/chtypes.h
new file mode 100644
index 000000000..56880c08a
--- /dev/null
+++ b/os/rt/ports/AVR/compilers/GCC/chtypes.h
@@ -0,0 +1,99 @@
+/*
+ ChibiOS/RT - Copyright (C) 2006,2007,2008,2009,2010,
+ 2011,2012,2013,2014 Giovanni Di Sirio.
+
+ This file is part of ChibiOS/RT.
+
+ ChibiOS/RT is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/RT is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file AVR/compilers/GCC/chtypes.h
+ * @brief AVR architecture port system types.
+ *
+ * @addtogroup AVR_CORE
+ * @{
+ */
+
+#ifndef _CHTYPES_H_
+#define _CHTYPES_H_
+
+#include <stddef.h>
+#include <stdint.h>
+#include <stdbool.h>
+
+/**
+ * @name Common constants
+ */
+/**
+ * @brief Generic 'false' boolean constant.
+ */
+#if !defined(FALSE) || defined(__DOXYGEN__)
+#define FALSE 0
+#endif
+
+/**
+ * @brief Generic 'true' boolean constant.
+ */
+#if !defined(TRUE) || defined(__DOXYGEN__)
+#define TRUE (!FALSE)
+#endif
+/** @} */
+
+typedef bool bool_t; /**< Fast boolean type. */
+typedef uint8_t syssts_t; /**< System status word. */
+typedef uint8_t tmode_t; /**< Thread flags. */
+typedef uint8_t tstate_t; /**< Thread state. */
+typedef uint8_t trefs_t; /**< Thread references counter. */
+typedef uint8_t tslices_t; /**< Thread time slices counter. */
+typedef uint8_t tprio_t; /**< Thread priority. */
+typedef int16_t msg_t; /**< Inter-thread message. */
+typedef uint8_t eventid_t; /**< Event Id. */
+typedef uint8_t eventmask_t; /**< Event mask. */
+typedef uint8_t eventflags_t; /**< Event flags. */
+typedef uint16_t systime_t; /**< System time. */
+typedef int8_t cnt_t; /**< Resources counter. */
+
+/**
+ * @brief Inline function modifier.
+ */
+#define INLINE inline
+
+/**
+ * @brief ROM constant modifier.
+ * @note It is set to use the "const" keyword in this port.
+ */
+#define ROMCONST const
+
+/**
+ * @brief Packed structure modifier (within).
+ * @note It uses the "packed" GCC attribute.
+ */
+#define PACK_STRUCT_STRUCT __attribute__((packed))
+
+/**
+ * @brief Packed structure modifier (before).
+ * @note Empty in this port.
+ */
+#define PACK_STRUCT_BEGIN
+
+/**
+ * @brief Packed structure modifier (after).
+ * @note Empty in this port.
+ */
+#define PACK_STRUCT_END
+
+#endif /* _CHTYPES_H_ */
+
+/** @} */
diff --git a/os/rt/ports/AVR/compilers/GCC/mk/port.mk b/os/rt/ports/AVR/compilers/GCC/mk/port.mk
new file mode 100644
index 000000000..ff129b8e0
--- /dev/null
+++ b/os/rt/ports/AVR/compilers/GCC/mk/port.mk
@@ -0,0 +1,7 @@
+# List of the ChibiOS/RT AVR port files.
+PORTSRC = ${CHIBIOS}/os/rt/ports/AVR/chcore.c
+
+PORTASM =
+
+PORTINC = ${CHIBIOS}/os/rt/ports/AVR \
+ ${CHIBIOS}/os/rt/ports/AVR/compilers/GCC