aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/AVR/TINY/platform.mk
diff options
context:
space:
mode:
authorTheodore Ateba <tf.ateba@gmail.com>2017-07-14 21:52:58 +0000
committerTheodore Ateba <tf.ateba@gmail.com>2017-07-14 21:52:58 +0000
commit631660116597bf80cc90d4aed5235cb4b46e2b27 (patch)
tree53a592554d189dd9e5e24962efe9724fcf4647eb /os/hal/ports/AVR/TINY/platform.mk
parent42278a5df96b1ccf5e64a0e81b1302ad0399aa54 (diff)
downloadChibiOS-631660116597bf80cc90d4aed5235cb4b46e2b27.tar.gz
ChibiOS-631660116597bf80cc90d4aed5235cb4b46e2b27.tar.bz2
ChibiOS-631660116597bf80cc90d4aed5235cb4b46e2b27.zip
Add NIL support for AVR Tiny architecture.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10332 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/AVR/TINY/platform.mk')
-rw-r--r--os/hal/ports/AVR/TINY/platform.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/os/hal/ports/AVR/TINY/platform.mk b/os/hal/ports/AVR/TINY/platform.mk
new file mode 100644
index 000000000..9635f6267
--- /dev/null
+++ b/os/hal/ports/AVR/TINY/platform.mk
@@ -0,0 +1,11 @@
+# List of all the AVR platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/AVR/TINY/hal_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/AVR/MEGA
+
+# Drivers compatible with the platform.
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/AVR/TINY
+include ${CHIBIOS}/os/hal/ports/AVR/TINY/GPIOv1/driver.mk
+include ${CHIBIOS}/os/hal/ports/AVR/TINY/TIMv1/driver.mk
+include ${CHIBIOS}/os/hal/ports/AVR/TINY/USARTv1/driver.mk