aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2015-08-20 17:47:21 +0200
committerFabien Poussin <fabien.poussin@gmail.com>2015-08-20 17:47:21 +0200
commit48a03708ff6ed34e7b0576e2c2b36587e58779d8 (patch)
tree84a8d07351e63cef2f1bada79ff160e13bf93562 /os/hal/ports/TIVA
parent3a945458c067f0fb2aeefd22ac928fe982da6c3a (diff)
downloadChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.tar.gz
ChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.tar.bz2
ChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.zip
Changed the way files are included to a more convenient way.
Diffstat (limited to 'os/hal/ports/TIVA')
-rw-r--r--os/hal/ports/TIVA/TM4C123x/platform.mk20
-rw-r--r--os/hal/ports/TIVA/TM4C129x/platform.mk14
2 files changed, 17 insertions, 17 deletions
diff --git a/os/hal/ports/TIVA/TM4C123x/platform.mk b/os/hal/ports/TIVA/TM4C123x/platform.mk
index e808142..e4e45ef 100644
--- a/os/hal/ports/TIVA/TM4C123x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C123x/platform.mk
@@ -1,17 +1,17 @@
# List of all the TM4C123x platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C123x/hal_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/st_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pal_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/serial_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/i2c_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/gpt_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pwm_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/spi_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C123x/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/pal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/i2c_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/pwm_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/spi_lld.c \
${CHISIOS}/community/os/hal/ports/TIVA/LLD/tiva_udma.c \
${CHISIOS}/community/os/hal/ports/TIVA/LLD/ext_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
- ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C123x \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C123x \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD
diff --git a/os/hal/ports/TIVA/TM4C129x/platform.mk b/os/hal/ports/TIVA/TM4C129x/platform.mk
index 97a5a73..6131ff0 100644
--- a/os/hal/ports/TIVA/TM4C129x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C129x/platform.mk
@@ -1,13 +1,13 @@
# List of all the TM4C129x platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C129x/hal_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/st_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pal_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/serial_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/mac_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C129x/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/pal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD/mac_lld.c \
${CHISIOS}/community/os/hal/ports/TIVA/LLD/ext_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
- ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C129x \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C129x \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/LLD