aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F0xx
diff options
context:
space:
mode:
authorMichael Spradling <mike@mspradling.com>2015-06-29 21:54:13 -0400
committerMichael Spradling <mike@mspradling.com>2015-08-16 01:26:07 -0400
commit316c3b4825689afca170576e5a5681302f64fdfa (patch)
treea00655dd3e1a38efa06b030f3051863a1eb15b2e /os/hal/ports/STM32/STM32F0xx
parentab80aabfd48b50e122f6ff43adeedd1af4a5a607 (diff)
downloadChibiOS-Contrib-316c3b4825689afca170576e5a5681302f64fdfa.tar.gz
ChibiOS-Contrib-316c3b4825689afca170576e5a5681302f64fdfa.tar.bz2
ChibiOS-Contrib-316c3b4825689afca170576e5a5681302f64fdfa.zip
Add CRC Driver
This patch includes a high level and two low level drivers. The high level driver is enabled with flag HAL_USE_CRC The low level drivers include: * Hardware CRC for the STM32 cortex processor lines.(when supported) * Enabled with flag STM32_CRC_USE_CRC1 * DMA is enabled with CRC_USE_DMA * SYNC api will use DMA, but put calling thread to sleep * ASYNC api enabled. * DMA Disabled * SYNC api spin while calculating CRC * ASYNC api disabled * Software CRC (3 modes) * CRCSW_CRC32_TABLE - Enables crc32 with lookup table. * CRCSW_CRC16_TABLE - Enables crc16 with lookup tables. * CRCSW_PROGRAMMBLE - Enables any crc done with computation. * Can calculate any crc configuration. * CRC_USE_DMA obviously not support with software CRC
Diffstat (limited to 'os/hal/ports/STM32/STM32F0xx')
-rw-r--r--os/hal/ports/STM32/STM32F0xx/platform.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/os/hal/ports/STM32/STM32F0xx/platform.mk b/os/hal/ports/STM32/STM32F0xx/platform.mk
new file mode 100644
index 0000000..c1c0650
--- /dev/null
+++ b/os/hal/ports/STM32/STM32F0xx/platform.mk
@@ -0,0 +1,6 @@
+include ${CHIBIOS}/os/hal/ports/STM32/STM32F0xx/platform.mk
+
+PLATFORMSRC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/CRCv1/crc_lld.c
+
+PLATFORMINC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/CRCv1 \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD