aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/LLD/ADCv1/driver.mk
diff options
context:
space:
mode:
authorDiego Ismirlian <dismirlian@gmail.com>2019-08-24 17:45:41 -0300
committerDiego Ismirlian <dismirlian@gmail.com>2019-08-24 17:45:41 -0300
commit7b2c61a676e024163057ec5ccc508a29ab3b9ed4 (patch)
tree5d1f5423a4e720d657681794ac81dc2a2004cbb0 /os/hal/ports/NRF5/LLD/ADCv1/driver.mk
parent81391097156ce2c9fc71c3350457522841e10095 (diff)
parente346e779339636f578536785014609e46866fb9c (diff)
downloadChibiOS-Contrib-7b2c61a676e024163057ec5ccc508a29ab3b9ed4.tar.gz
ChibiOS-Contrib-7b2c61a676e024163057ec5ccc508a29ab3b9ed4.tar.bz2
ChibiOS-Contrib-7b2c61a676e024163057ec5ccc508a29ab3b9ed4.zip
Merge branch 'master' of https://github.com/ChibiOS/ChibiOS-Contrib
Diffstat (limited to 'os/hal/ports/NRF5/LLD/ADCv1/driver.mk')
-rw-r--r--os/hal/ports/NRF5/LLD/ADCv1/driver.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/os/hal/ports/NRF5/LLD/ADCv1/driver.mk b/os/hal/ports/NRF5/LLD/ADCv1/driver.mk
new file mode 100644
index 0000000..88deb3e
--- /dev/null
+++ b/os/hal/ports/NRF5/LLD/ADCv1/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/ADCv1/hal_adc_lld.c
+endif
+else
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/ADCv1/hal_adc_lld.c
+endif
+
+PLATFORMINC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/ADCv1