aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rtl838x/image/Makefile')
-rw-r--r--target/linux/rtl838x/image/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
deleted file mode 100644
index 266759220f..0000000000
--- a/target/linux/rtl838x/image/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-KERNEL_LOADADDR = 0x80000000
-KERNEL_ENTRY = 0x80000400
-
-define Device/Default
- PROFILES = Default
- KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
- KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
- DEVICE_DTS_DIR := ../dts
- DEVICE_DTS = $$(SOC)_$(1)
- SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
- append-metadata | check-size
-endef
-
-define Device/allnet_all-sg8208m
- SOC := rtl8382
- IMAGE_SIZE := 7168k
- DEVICE_VENDOR := ALLNET
- DEVICE_MODEL := ALL-SG8208M
- UIMAGE_MAGIC := 0x00000006
- UIMAGE_NAME := 2.2.2.0
- DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
-endef
-TARGET_DEVICES += allnet_all-sg8208m
-
-define Device/d-link_dgs-1210
- SOC := rtl8382
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
- DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
-endef
-
-define Device/d-link_dgs-1210-10p
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-10P
- DEVICE_PACKAGES += lua-rs232
-endef
-TARGET_DEVICES += d-link_dgs-1210-10p
-
-define Device/d-link_dgs-1210-16
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-16
-endef
-TARGET_DEVICES += d-link_dgs-1210-16
-
-define Device/d-link_dgs-1210-28
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-28
-endef
-TARGET_DEVICES += d-link_dgs-1210-28
-$(eval $(call BuildImage))