aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/common-sercomm.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/common-sercomm.mk b/target/linux/ramips/image/common-sercomm.mk
index 1cd6d1ece7..83bb2a742c 100644
--- a/target/linux/ramips/image/common-sercomm.mk
+++ b/target/linux/ramips/image/common-sercomm.mk
@@ -51,7 +51,7 @@ define Build/sercomm-payload
$(TOPDIR)/scripts/sercomm-payload.py \
--input-file $@ \
--output-file $@.tmp \
- --pid "$$(cat $@.pid | od -t x1 -An -v | tr -d '\n')"
+ --pid-file $@.pid
mv $@.tmp $@
rm $@.pid
endef