aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 09:59:21 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2023-04-09 09:59:21 +0200
commit8758438c27a88694a1389a42f82b8262d6a92f97 (patch)
treec67087b5c0b5510cbfb8aca524d9c8b7423ba191
parent8382c5662e57e00e7841e6f1e85e89b66b09eff1 (diff)
downloadupstream-8758438c27a88694a1389a42f82b8262d6a92f97.tar.gz
upstream-8758438c27a88694a1389a42f82b8262d6a92f97.tar.bz2
upstream-8758438c27a88694a1389a42f82b8262d6a92f97.zip
ramips: sercomm-payload: use pide-file argument
Instead of passing an array of hex bytes for the Sercomm PID we can now use the --pid-file parameter. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
-rw-r--r--target/linux/ramips/image/common-sercomm.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/common-sercomm.mk b/target/linux/ramips/image/common-sercomm.mk
index 1cd6d1ece7..83bb2a742c 100644
--- a/target/linux/ramips/image/common-sercomm.mk
+++ b/target/linux/ramips/image/common-sercomm.mk
@@ -51,7 +51,7 @@ define Build/sercomm-payload
$(TOPDIR)/scripts/sercomm-payload.py \
--input-file $@ \
--output-file $@.tmp \
- --pid "$$(cat $@.pid | od -t x1 -An -v | tr -d '\n')"
+ --pid-file $@.pid
mv $@.tmp $@
rm $@.pid
endef