aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-12 17:51:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-12 17:51:31 +0000
commit02486e1b0bf8c62bf034186d5c155431663d6a0e (patch)
tree1a4fe2fbd32c4656d56b4f9929dc8625f0f4c60e /target
parent2239e4dab21c8b4aea4155e7f89877de2be9e1f1 (diff)
downloadupstream-02486e1b0bf8c62bf034186d5c155431663d6a0e.tar.gz
upstream-02486e1b0bf8c62bf034186d5c155431663d6a0e.tar.bz2
upstream-02486e1b0bf8c62bf034186d5c155431663d6a0e.zip
fix squashfs build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1219 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/image/squashfs.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/image/squashfs.mk b/target/linux/image/squashfs.mk
index e9a95de560..917a69ab8a 100644
--- a/target/linux/image/squashfs.mk
+++ b/target/linux/image/squashfs.mk
@@ -12,8 +12,9 @@ $(KDIR)/root.squashfs:
@mkdir -p $(KDIR)/root/jffs
$(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+squashfs-install: $(KDIR)/root.squashfs
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
+
prepare: squashfs-prepare
compile: squashfs-compile
-install: $(KDIR)/root.squashfs
- $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-
+install: squashfs-install