aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-04-11 13:22:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-04-11 13:22:24 +0000
commitf7e747baa9ed27056eba2a4215fb054e4cefb53c (patch)
treee9d269489c279bfe4f5a5be329fabc0d41c28482 /target/linux/x86/Makefile
parentc3cc517071ac505296c57ef2d68557db374d0746 (diff)
downloadupstream-f7e747baa9ed27056eba2a4215fb054e4cefb53c.tar.gz
upstream-f7e747baa9ed27056eba2a4215fb054e4cefb53c.tar.bz2
upstream-f7e747baa9ed27056eba2a4215fb054e4cefb53c.zip
x86: set default kernel version to 3.10
Place the previous selection (3.3.8) into the only subtarget that did not override it to 3.10 Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40454
Diffstat (limited to 'target/linux/x86/Makefile')
-rw-r--r--target/linux/x86/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 0d4fe4764f..b589cd5b59 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
rdc
-LINUX_VERSION:=3.3.8
+LINUX_VERSION:=3.10.34
KERNELNAME:=bzImage
Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
# FabulousAnomalyKeyBoard

This layout features an efficient layout for people without
a mouse.

## layers

Layer Base:	complete basic keyboard
Layer Fn-Tab:	F1-F12, Arrow Keys, Home, End, Backlight, Media
Layer Fn-Space: mouse keys in a vim like manner

For detailed info check out keymap.c

## the CTRL key

It is where you would suspect CAPSLOCK to be.
WHO NEEDS CAPSLOCK ANYWAYS?
For those rare cases you need to shout at somebody in a comment
section you can still do a capslock by using TAB+CTRL

## SUPER key

There are two super keys. They are next to the space bar.
The intention is easing the use of tiling window mangers

## emergency mouse

Without a mouse you will find yourself in a situation where all
your tiling goodness will just not be able to click onto that 
"close ads" button.
This keymap integrates a basic mouse pointer directly into the keyboard.
Mouse is accessible via holding SPACE and tapping keys:
```
SPACE+
h	Move cursor left
j	Move cursor down
k	Move cursor up
l	Move cursor right

w	Middle Mouse Click
r	Right click
e	Left click

s	Scroll wheel left
d	Scroll wheel down
f	Scroll wheel up
g	Scroll wheel right
```

## shell focused

Working in a shell the up and down arrow keys are often needed to
look at old commands or reuse some.
When held, the left ctrl and left shift will act as expected,
but when tapped they will become UP and DOWN arrow-keys.

## krautfriend
The keys <|> are accessible even without a 102nd key