aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/armv8.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-11-13 21:29:26 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-11-14 22:50:21 +0800
commitc984fc762412f206ebeb3e873742988ff760fb90 (patch)
treedee0a969f2fcf96d81804a5bc6a2b468826092a2 /target/linux/rockchip/image/armv8.mk
parent6fdeb48c1ec207e7952bfff1596b65626fb336fd (diff)
downloadupstream-c984fc762412f206ebeb3e873742988ff760fb90.tar.gz
upstream-c984fc762412f206ebeb3e873742988ff760fb90.tar.bz2
upstream-c984fc762412f206ebeb3e873742988ff760fb90.zip
rockchip: use LZMA FIT for kernel image
Use LZMA compressed kernel to save some space in boot partition. Fixes: #11197 Tested-by: Tianling Shen <cnsztl@immortalwrt.org> [NanoPi R2S] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/rockchip/image/armv8.mk')
-rw-r--r--target/linux/rockchip/image/armv8.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
index 6cc31f1d8c..f95416323d 100644
--- a/target/linux/rockchip/image/armv8.mk
+++ b/target/linux/rockchip/image/armv8.mk
@@ -2,6 +2,9 @@
#
# Copyright (C) 2020 Tobias Maedel
+# FIT will be loaded at 0x02080000. Leave 16M for that, align it to 2M and load the kernel after it.
+KERNEL_LOADADDR := 0x03200000
+
define Device/friendlyarm_nanopi-r2s
DEVICE_VENDOR := FriendlyARM
DEVICE_MODEL := NanoPi R2S