aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2021-05-05 09:32:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 00:32:17 +0200
commit95170b4350ec6dcadd4dc740c130709c46aa6ecb (patch)
tree3280bba44b875daf116b57a3d27f8f13bab8c47c /target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch
parent1edc7078d6549a7ff39d62318d2879ee72bd0b9d (diff)
downloadupstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.tar.gz
upstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.tar.bz2
upstream-95170b4350ec6dcadd4dc740c130709c46aa6ecb.zip
realtek: copy config/files/patches to 5.10
this patch copies the following files from 5.4 to 5.10: - config-5.4 -> config-5.10 - files-5.4/ -> files-5.10/ - patches-5.4/ -> patches-5.10/ Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [rebase on change in files-5.4] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch')
-rw-r--r--target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch
new file mode 100644
index 0000000000..bb6f83e55d
--- /dev/null
+++ b/target/linux/realtek/patches-5.10/700-net-dsa-add-support-for-rtl838x-switch.patch
@@ -0,0 +1,18 @@
+--- a/drivers/net/dsa/Kconfig
++++ b/drivers/net/dsa/Kconfig
+@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
+ This enables support for the Qualcomm Atheros QCA8K Ethernet
+ switch chips.
+
++source "drivers/net/dsa/rtl83xx/Kconfig"
++
+ config NET_DSA_REALTEK_SMI
+ tristate "Realtek SMI Ethernet switch family support"
+ depends on NET_DSA
+--- a/drivers/net/dsa/Makefile
++++ b/drivers/net/dsa/Makefile
+@@ -21,3 +21,4 @@ obj-y += b53/
+ obj-y += microchip/
+ obj-y += mv88e6xxx/
+ obj-y += sja1105/
++obj-y += rtl83xx/