aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAlessio Prescenzo <alessioprescenzo@gmail.com>2021-09-22 16:45:19 +0200
committerDavid Bauer <mail@david-bauer.net>2022-05-09 15:31:01 +0200
commit4a8eaa5c7c9235212c4af022c18b2dfbadfe557f (patch)
treebae067aa3176872262f095d4541dd80692c8db2e /target/linux/ramips/image/mt7621.mk
parent98bb26f9f762408e42bd8a906f0eb01c41ada10a (diff)
downloadupstream-4a8eaa5c7c9235212c4af022c18b2dfbadfe557f.tar.gz
upstream-4a8eaa5c7c9235212c4af022c18b2dfbadfe557f.tar.bz2
upstream-4a8eaa5c7c9235212c4af022c18b2dfbadfe557f.zip
ramips: add support for Cudy X6
Specifications: SoC: MediaTek MT7621 RAM: 256 MB Flash: 32 MB WiFi: MediaTek MT7915E Switch: 1 WAN, 4 LAN (Gigabit) Ports: 1 USB 3.0 Buttons: Reset, WPS LEDs: Power, System, Wan, Lan 1-4, WiFi 2.4G, WiFi 5G, WPS, USB Power: DC 12V 1A tip positive Installation: Download and flash the manufacturer's built OpenWRT image available at http://www.cudytech.com/openwrt_software_download Install the new OpenWRT image via luci (System -> Backup/Flash firmware) Be sure to NOT keep settings. The force upgrade may need to be checked due to differences in router naming conventions. Recovery: Loads only signed manufacture firmware due to bootloader RSA verification serve tftp-recovery image as /recovery.bin on 192.168.1.88/24 connect to any lan ethernet port power on the device while holding the reset button wait at least 8 seconds before releasing reset button for image to download Signed-off-by: Alessio Prescenzo <alessioprescenzo@gmail.com> [ensure unique wireless MAC, fix GPIO pingroup] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 5844682a40..cbdc63247d 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -318,6 +318,16 @@ define Device/cudy_wr2100
endef
TARGET_DEVICES += cudy_wr2100
+define Device/cudy_x6
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 32256k
+ DEVICE_VENDOR := Cudy
+ DEVICE_MODEL := X6
+ UIMAGE_NAME := R13
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += cudy_x6
+
define Device/dlink_dir-8xx-a1
$(Device/dsa-migration)
IMAGE_SIZE := 16000k