aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-08-14 21:07:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-08-14 21:07:42 +0000
commita1bee93fa0c3cdf8ea94d1ddcc46872a404bb2ff (patch)
tree21652a56d55e18f8c1d885231ed18780c87d5770 /target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch
parent78478d79736b35de7d3aaaeb988a10f96566971a (diff)
downloadupstream-a1bee93fa0c3cdf8ea94d1ddcc46872a404bb2ff.tar.gz
upstream-a1bee93fa0c3cdf8ea94d1ddcc46872a404bb2ff.tar.bz2
upstream-a1bee93fa0c3cdf8ea94d1ddcc46872a404bb2ff.zip
ixp4xx: refresh patches
SVN-Revision: 22649
Diffstat (limited to 'target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch')
-rw-r--r--target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch b/target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch
index e173ac6e4e..af4eadaee8 100644
--- a/target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch
+++ b/target/linux/ixp4xx/patches-2.6.34/295-latch_led_driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -157,6 +157,13 @@ config LEDS_LP3944
+@@ -166,6 +166,13 @@ config LEDS_LP3944
To compile this driver as a module, choose M here: the
module will be called leds-lp3944.
@@ -13,7 +13,7 @@
+
config LEDS_CLEVO_MAIL
tristate "Mail LED on Clevo notebook"
- depends on LEDS_CLASS && X86 && SERIO_I8042 && DMI
+ depends on X86 && SERIO_I8042 && DMI
--- /dev/null
+++ b/drivers/leds/leds-latch.c
@@ -0,0 +1,150 @@
@@ -169,7 +169,7 @@
+MODULE_LICENSE("GPL");
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -20,6 +20,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-c
+@@ -21,6 +21,7 @@ obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-c
obj-$(CONFIG_LEDS_SUNFIRE) += leds-sunfire.o
obj-$(CONFIG_LEDS_PCA9532) += leds-pca9532.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o