aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/aruba/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-31 02:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-31 02:32:29 +0000
commitf0657ba0c28e55a02f19aff050c24de4826cde70 (patch)
tree4c63bd906914018625f509e83f4cbf425ad68165 /target/linux/image/aruba/Makefile
parent131d551def29bd0bf1fa0c23ac8b6165080495d5 (diff)
downloadupstream-f0657ba0c28e55a02f19aff050c24de4826cde70.tar.gz
upstream-f0657ba0c28e55a02f19aff050c24de4826cde70.tar.bz2
upstream-f0657ba0c28e55a02f19aff050c24de4826cde70.zip
make aruba lzma loader more generic and move it to target/linux/image/generic/lzma-loader
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3076 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image/aruba/Makefile')
-rw-r--r--target/linux/image/aruba/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/target/linux/image/aruba/Makefile b/target/linux/image/aruba/Makefile
index 432a85d59e..2a7f2e4682 100644
--- a/target/linux/image/aruba/Makefile
+++ b/target/linux/image/aruba/Makefile
@@ -1,15 +1,25 @@
include $(TOPDIR)/rules.mk
+LOADADDR = 0x81000000 # RAM start + 16M
+KERNEL_ENTRY = 0x80100000
+RAMSIZE = 0x00100000 # 1MB
+
+LOADER_MAKEOPTS= \
+ KDIR=$(KDIR) \
+ LOADADDR=$(LOADADDR) \
+ KERNEL_ENTRY=$(KERNEL_ENTRY) \
+ RAMSIZE=$(RAMSIZE)
+
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
lzma-loader-clean:
- $(MAKE) -C lzma-loader clean
+ $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) clean
lzma-loader-prepare:
- $(MAKE) -C lzma-loader prepare
+ $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) prepare
lzma-loader-compile: $(KDIR)/vmlinux.lzma lzma-loader-prepare
- $(MAKE) -C lzma-loader compile KDIR=$(KDIR)
+ $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) compile
ifeq ($(IB),)
$(KDIR)/vmlinux.lzma: $(KDIR)/vmlinux