aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commitb49e97601bba8ba4075085b69e00952373e18af2 (patch)
tree322fc313a19bc903c788a7acf9b6fabef06b04e5 /target/linux/generic/patches-3.2/830-ledtrig_morse.patch
parentef7ec19360f373ead4bffc66c10fd70ec6c1aa78 (diff)
downloadupstream-b49e97601bba8ba4075085b69e00952373e18af2.tar.gz
upstream-b49e97601bba8ba4075085b69e00952373e18af2.tar.bz2
upstream-b49e97601bba8ba4075085b69e00952373e18af2.zip
kernel: add support for linux 3.2.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29730 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.2/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-3.2/830-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/830-ledtrig_morse.patch b/target/linux/generic/patches-3.2/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..e91e93a52a
--- /dev/null
+++ b/target/linux/generic/patches-3.2/830-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -457,4 +457,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -54,3 +54,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o