aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
commit7adb67f18469e51cecb83a0c2efbf22494acb244 (patch)
treefe225b163b00d82bf2dfa88ec105309675690049 /target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch
parent52d975c359b8330e2844d3bb942588bd5afd73e6 (diff)
downloadupstream-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.gz
upstream-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.bz2
upstream-7adb67f18469e51cecb83a0c2efbf22494acb244.zip
revert 15922 - add back 2.6.29 kernel support
SVN-Revision: 16127
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..f9a63d6bf8
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -223,4 +223,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ This allows LEDs to be initialised in the ON state.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -31,3 +31,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o