aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-06-02 00:46:02 +0000
committerJohn Crispin <blogic@openwrt.org>2007-06-02 00:46:02 +0000
commit5f63e4ddcc5847aba27e8bea15853835f3468941 (patch)
treed4161d76c676ff352e44294ba8819194d66356c4 /target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
parent9a4964868b01d5b838669d7b8ecaec0991700124 (diff)
downloadupstream-5f63e4ddcc5847aba27e8bea15853835f3468941.tar.gz
upstream-5f63e4ddcc5847aba27e8bea15853835f3468941.tar.bz2
upstream-5f63e4ddcc5847aba27e8bea15853835f3468941.zip
add initial support for the crisarchitecture used on foxboards to openwrt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7439 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/etrax-2.6/image/e100boot/src/doc/Makefile')
-rw-r--r--target/linux/etrax-2.6/image/e100boot/src/doc/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile b/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
new file mode 100644
index 0000000000..df6076b8e2
--- /dev/null
+++ b/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
@@ -0,0 +1,17 @@
+OBJS=e100boot.1 e100boot.html
+
+all: $(OBJS)
+
+%.1: %.pod
+ pod2man $< > $@
+
+%.html: %.pod
+ pod2html $< > $@
+ @rm -f pod2htmd.x~~ pod2htmi.x~~
+
+clean:
+ rm -f *cache *~
+
+# The 'clean' doesn't remove the generated documentation as we want
+# them in the distribution.
+