aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-07-04 01:35:43 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-11 12:53:34 +0200
commitac34f6469ecf07cdeb32f65788192262fd8e0100 (patch)
tree262ff6cabed957fc2fc2020d7c8ff64d41cff51f /target/linux/ath79/image/generic-ubnt.mk
parent1a33e4b9520153de44ca3dfb9b1e9819f18cac65 (diff)
downloadupstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.tar.gz
upstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.tar.bz2
upstream-ac34f6469ecf07cdeb32f65788192262fd8e0100.zip
ath79: move ubnt-xm 64M RAM boards back to generic
return ubnt_rocket-m and ubnt_powerbridge-m back to ath79-generic They have enough RAM-ressources to not be considered as tiny. This reverts the commit f4415f7635164ec07ddc22f56df93555804b5767 partially Signed-off-by: Felix Baumann <felix.bau@gmx.de> (cherry picked from commit 9e86a96af5ecea6e73fa463d6cfa4408e2b49d35)
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 0f70649d03..fa4daa3aaa 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -158,6 +158,15 @@ define Device/ubnt_powerbeam-m5-xw
endef
TARGET_DEVICES += ubnt_powerbeam-m5-xw
+define Device/ubnt_powerbridge-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := PowerBridge M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += bullet-m
+endef
+TARGET_DEVICES += ubnt_powerbridge-m
+
define Device/ubnt_rocket-5ac-lite
$(Device/ubnt-xc)
SOC := qca9558
@@ -167,6 +176,15 @@ define Device/ubnt_rocket-5ac-lite
endef
TARGET_DEVICES += ubnt_rocket-5ac-lite
+define Device/ubnt_rocket-m
+ $(Device/ubnt-xm)
+ SOC := ar7241
+ DEVICE_MODEL := Rocket M
+ DEVICE_PACKAGES += rssileds
+ SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m
+
define Device/ubnt_routerstation_common
DEVICE_PACKAGES := -kmod-ath9k -wpad-basic-mbedtls -uboot-envtools kmod-usb-ohci \
kmod-usb2 fconfig