aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-02 13:01:18 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-02 13:01:18 +0000
commitad1c9dde15aa5775d2f625ac993cafe20127e446 (patch)
tree01648884f5d475e93d2d3a37c4f0c757acc628db /target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch
parentd96cfaeb1abf9088f499bd10071133a5b5d537d4 (diff)
downloadupstream-ad1c9dde15aa5775d2f625ac993cafe20127e446.tar.gz
upstream-ad1c9dde15aa5775d2f625ac993cafe20127e446.tar.bz2
upstream-ad1c9dde15aa5775d2f625ac993cafe20127e446.zip
[ar7] add experimental support for 2.6.30
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17097 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch')
-rw-r--r--target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch b/target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch
new file mode 100644
index 0000000000..fa61e5ccf5
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.30/120-gpio_chrdev.patch
@@ -0,0 +1,28 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -974,6 +974,15 @@ config MWAVE
+ To compile this driver as a module, choose M here: the
+ module will be called mwave.
+
++config AR7_GPIO
++ tristate "TI AR7 GPIO Support"
++ depends on AR7
++ help
++ Give userspace access to the GPIO pins on the Texas Instruments AR7
++ processors.
++
++ If compiled as a module, it will be called ar7_gpio.
++
+ config SCx200_GPIO
+ tristate "NatSemi SCx200 GPIO Support"
+ depends on SCx200
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -90,6 +90,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
+ obj-$(CONFIG_PPDEV) += ppdev.o
+ obj-$(CONFIG_NWBUTTON) += nwbutton.o
+ obj-$(CONFIG_NWFLASH) += nwflash.o
++obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o