aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/image/nand.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-18 13:14:28 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-21 11:56:35 +0200
commiteff0a0e39e48e4d1d40fc2262f1394d6d391a8c0 (patch)
treeb89261013e56a416c82bd79bf9e97e44b436cec2 /target/linux/apm821xx/image/nand.mk
parenta2fee73e270305c4cb086055cc30e97f65e6f58b (diff)
downloadupstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.gz
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.tar.bz2
upstream-eff0a0e39e48e4d1d40fc2262f1394d6d391a8c0.zip
apm821xx: derive DEVICE_DTS from device name
The DEVICE_DTS variable always matches the device definition name, just with "_" replaced by "-". Thus, create a DEVICE_DTS definition in Device/Default and drop all the individual statements. If necessary in the future, local DEVICE_DTS will still overwrite that default. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/apm821xx/image/nand.mk')
-rw-r--r--target/linux/apm821xx/image/nand.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/target/linux/apm821xx/image/nand.mk b/target/linux/apm821xx/image/nand.mk
index a7338e79a0..29a4be0189 100644
--- a/target/linux/apm821xx/image/nand.mk
+++ b/target/linux/apm821xx/image/nand.mk
@@ -29,7 +29,6 @@ define Device/meraki_mr24
DEVICE_MODEL := MR24
DEVICE_PACKAGES := kmod-spi-gpio -swconfig
BOARD_NAME := mr24
- DEVICE_DTS := meraki-mr24
IMAGES := sysupgrade.bin
DTB_SIZE := 64512
IMAGE_SIZE := 8191k
@@ -47,7 +46,6 @@ define Device/meraki_mx60
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-ledtrig-usbport kmod-usb-dwc2 \
kmod-usb-storage block-mount
BOARD_NAME := mx60
- DEVICE_DTS := meraki-mx60
BLOCKSIZE := 63k
IMAGES := sysupgrade.bin
DTB_SIZE := 64512
@@ -80,14 +78,12 @@ endef
define Device/netgear_wndap620
$(Device/netgear_wndap6x0)
DEVICE_MODEL := WNDAP620 (Premium Wireless-N)
- DEVICE_DTS := netgear-wndap620
endef
TARGET_DEVICES += netgear_wndap620
define Device/netgear_wndap660
$(Device/netgear_wndap6x0)
DEVICE_MODEL := WNDAP660 (Dual Radio Dual Band Wireless-N)
- DEVICE_DTS := netgear-wndap660
endef
TARGET_DEVICES += netgear_wndap660
@@ -100,7 +96,6 @@ define Device/netgear_wndr4700
kmod-nls-utf8 kmod-usb3 kmod-usb-dwc2 kmod-usb-storage \
partx-utils
BOARD_NAME := wndr4700
- DEVICE_DTS := netgear-wndr4700
PAGESIZE := 2048
SUBPAGESIZE := 512
BLOCKSIZE := 128k