aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-12 17:06:16 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-12 17:06:16 +0000
commitf1924d71478c74a925585f87da558c5093252b3f (patch)
treeaaaae00d2be81463629f4a72c28458af2cbea509 /target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch
parent41aadece1d92bb8869fc151f3306ee8c35ce5096 (diff)
downloadupstream-f1924d71478c74a925585f87da558c5093252b3f.tar.gz
upstream-f1924d71478c74a925585f87da558c5093252b3f.tar.bz2
upstream-f1924d71478c74a925585f87da558c5093252b3f.zip
linux/adm5120: add preliminary 2.6.37 kernel support
SVN-Revision: 23973
Diffstat (limited to 'target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch
new file mode 100644
index 0000000000..3df59fd715
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.37/002-adm5120_flash.patch
@@ -0,0 +1,21 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -552,4 +552,8 @@ config MTD_PISMO
+
+ When built as a module, it will be called pismo.ko
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on ADM5120
++
+ endmenu
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -40,6 +40,7 @@ obj-$(CONFIG_MTD_SCx200_DOCFLASH)+= scx2
+ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.o
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o