aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-10-08 11:13:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-10-08 11:13:10 +0000
commit267c50a1abf9c70ec1d9f93624f92f3a0b2680fc (patch)
tree16e1da78ffaa8b3b7311fe958bf9808df1467f95 /target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
parent95f55531694ae1d81b2808a2fc515c56908428e4 (diff)
downloadupstream-267c50a1abf9c70ec1d9f93624f92f3a0b2680fc.tar.gz
upstream-267c50a1abf9c70ec1d9f93624f92f3a0b2680fc.tar.bz2
upstream-267c50a1abf9c70ec1d9f93624f92f3a0b2680fc.zip
adm5120: add preliminary support for 2.6.31
SVN-Revision: 18000
Diffstat (limited to 'target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
new file mode 100644
index 0000000000..6fe5f3b3fc
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.31/009-adm5120_leds_switch_trigger.patch
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -308,4 +308,12 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_ADM5120_SWITCH
++ tristate "LED ADM5120 Switch Port Status Trigger"
++ depends on LEDS_TRIGGERS && ADM5120
++ help
++ This allows LEDs to be controlled by the port states of
++ the ADM5120 built-in Ethernet Switch
++ If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -41,3 +41,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o