aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-10 09:56:42 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-10 09:56:42 +0000
commitf70d9decda9f62df9dbe39bcc3b0e92888218ec5 (patch)
tree494fede4a494afc43c0290e997c130eff73ddead
parenta2d6de33b5718850208eca17a3943ab373209831 (diff)
downloadupstream-f70d9decda9f62df9dbe39bcc3b0e92888218ec5.tar.gz
upstream-f70d9decda9f62df9dbe39bcc3b0e92888218ec5.tar.bz2
upstream-f70d9decda9f62df9dbe39bcc3b0e92888218ec5.zip
override default configure to use --target=host and --build=host (closes: #760)
SVN-Revision: 4779
-rw-r--r--openwrt/toolchain/ext2fs/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/openwrt/toolchain/ext2fs/Makefile b/openwrt/toolchain/ext2fs/Makefile
index 0bd24f8fa9..eebf7a2c88 100644
--- a/openwrt/toolchain/ext2fs/Makefile
+++ b/openwrt/toolchain/ext2fs/Makefile
@@ -19,6 +19,27 @@ PKG_CAT:=zcat
include $(INCLUDE_DIR)/host-build.mk
+define Build/Configure
+ ( cd $(PKG_BUILD_DIR); \
+ ./configure \
+ --target=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ )
+endef
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all
endef