aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2022-10-19 11:21:58 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-31 21:58:15 +0100
commitda5c45f4d8864a82378b4a04c0516cb98a718cfa (patch)
tree88f1db24f44673b04c0ffe71e9b338d1c1d3b3e2
parent23a456aef1ac5c66f7bc5dc45ba2bc5980dbc513 (diff)
downloadupstream-da5c45f4d8864a82378b4a04c0516cb98a718cfa.tar.gz
upstream-da5c45f4d8864a82378b4a04c0516cb98a718cfa.tar.bz2
upstream-da5c45f4d8864a82378b4a04c0516cb98a718cfa.zip
kernel: remove handling of xfrm[4|6]_mode_* modules
For kernel versions before 5.2, the required IPsec modes have to be enabled explicitly (they are built-in for newer kernels). Commit 1556ed155a9a ("kernel: mode_beet mode_transport mode_tunnel xfram modules") tried to handle this, but it does not really work. Since we don't support these kernel versions anymore and the code is also broken, let's remove it. Signed-off-by: Martin Schiller <ms@dev.tdt.de> [Remove old generic config options too] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/netsupport.mk14
-rw-r--r--target/linux/generic/config-5.103
-rw-r--r--target/linux/generic/config-5.153
3 files changed, 2 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 9afee41aed..0fc3b5cce3 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -215,10 +215,8 @@ $(eval $(call KernelPackage,ipsec))
IPSEC4-m = \
ipv4/ah4 \
ipv4/esp4 \
- ipv4/xfrm4_tunnel \
ipv4/ipcomp \
-
-IPSEC4-m += $(ifeq ($$(strip $$(call CompareKernelPatchVer,$$(KERNEL_PATCHVER),le,5.2))),ipv4/xfrm4_mode_beet ipv4/xfrm4_mode_transport ipv4/xfrm4_mode_tunnel)
+ ipv4/xfrm4_tunnel
define KernelPackage/ipsec4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
@@ -228,9 +226,6 @@ define KernelPackage/ipsec4
CONFIG_INET_AH \
CONFIG_INET_ESP \
CONFIG_INET_IPCOMP \
- CONFIG_INET_XFRM_MODE_BEET \
- CONFIG_INET_XFRM_MODE_TRANSPORT \
- CONFIG_INET_XFRM_MODE_TUNNEL \
CONFIG_INET_XFRM_TUNNEL \
CONFIG_INET_ESP_OFFLOAD=n
FILES:=$(foreach mod,$(IPSEC4-m),$(LINUX_DIR)/net/$(mod).ko)
@@ -255,10 +250,8 @@ $(eval $(call KernelPackage,ipsec4))
IPSEC6-m = \
ipv6/ah6 \
ipv6/esp6 \
- ipv6/xfrm6_tunnel \
ipv6/ipcomp6 \
-
-IPSEC6-m += $(ifeq ($$(strip $$(call CompareKernelPatchVer,$$(KERNEL_PATCHVER),le,5.2))),ipv6/xfrm6_mode_beet ipv6/xfrm6_mode_transport ipv6/xfrm6_mode_tunnel)
+ ipv6/xfrm6_tunnel
define KernelPackage/ipsec6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
@@ -268,9 +261,6 @@ define KernelPackage/ipsec6
CONFIG_INET6_AH \
CONFIG_INET6_ESP \
CONFIG_INET6_IPCOMP \
- CONFIG_INET6_XFRM_MODE_BEET \
- CONFIG_INET6_XFRM_MODE_TRANSPORT \
- CONFIG_INET6_XFRM_MODE_TUNNEL \
CONFIG_INET6_XFRM_TUNNEL \
CONFIG_INET6_ESP_OFFLOAD=n
FILES:=$(foreach mod,$(IPSEC6-m),$(LINUX_DIR)/net/$(mod).ko)
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index cef0c7d0a8..4b2837de05 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -2554,9 +2554,6 @@ CONFIG_INET=y
# CONFIG_INET_TCP_DIAG is not set
# CONFIG_INET_TUNNEL is not set
# CONFIG_INET_UDP_DIAG is not set
-# CONFIG_INET_XFRM_MODE_BEET is not set
-# CONFIG_INET_XFRM_MODE_TRANSPORT is not set
-# CONFIG_INET_XFRM_MODE_TUNNEL is not set
# CONFIG_INET_XFRM_TUNNEL is not set
# CONFIG_INFINIBAND is not set
# CONFIG_INFTL is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index 8b2d6b5491..1e49471ae2 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -2655,9 +2655,6 @@ CONFIG_INET=y
# CONFIG_INET_TCP_DIAG is not set
# CONFIG_INET_TUNNEL is not set
# CONFIG_INET_UDP_DIAG is not set
-# CONFIG_INET_XFRM_MODE_BEET is not set
-# CONFIG_INET_XFRM_MODE_TRANSPORT is not set
-# CONFIG_INET_XFRM_MODE_TUNNEL is not set
# CONFIG_INET_XFRM_TUNNEL is not set
# CONFIG_INFINIBAND is not set
# CONFIG_INFTL is not set