diff options
author | Mike Baker <mbm@openwrt.org> | 2007-04-03 11:56:08 +0000 |
---|---|---|
committer | Mike Baker <mbm@openwrt.org> | 2007-04-03 11:56:08 +0000 |
commit | d5d59e30ea677bddcf5ce0bfd7f3cd170b12d319 (patch) | |
tree | a163818608f061265fb7998475f8fb1832bcbeaf | |
parent | 2e68ff9a889a98c85dcde08212a53c59435f1c65 (diff) | |
download | upstream-d5d59e30ea677bddcf5ce0bfd7f3cd170b12d319.tar.gz upstream-d5d59e30ea677bddcf5ce0bfd7f3cd170b12d319.tar.bz2 upstream-d5d59e30ea677bddcf5ce0bfd7f3cd170b12d319.zip |
Using find's -exec to remove directories causes 'not found' errors when find tries to search the removed directory. Hopefully fixed now.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6849 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | include/package-ipkg.mk | 6 | ||||
-rwxr-xr-x | scripts/feeds.sh | 2 |
3 files changed, 5 insertions, 5 deletions
@@ -171,7 +171,7 @@ docclean: $(MAKE) -C docs/ clean symlinkclean: - find package -type l -exec rm -f {} \; + find package -type l -exec rm -f {} + .SILENT: clean dirclean distclean symlinkclean config-clean download world FORCE: ; diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk index d824d268f4..8b317065bf 100644 --- a/include/package-ipkg.mk +++ b/include/package-ipkg.mk @@ -71,9 +71,9 @@ ifeq ($(DUMP),) $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control $(call Package/$(1)/install,$$(IDIR_$(1))) mkdir -p $(PACKAGE_DIR) - -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} \; - -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} \; - -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} \; + -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} + + -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} + + -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} + $(RSTRIP) $$(IDIR_$(1)) $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR) @[ -f $$(IPKG_$(1)) ] || false diff --git a/scripts/feeds.sh b/scripts/feeds.sh index d2dfe9da9f..9fc3343a1b 100755 --- a/scripts/feeds.sh +++ b/scripts/feeds.sh @@ -22,7 +22,7 @@ cd $TOPDIR # Some functions we might call several times a run delete_symlinks() { - find $1 -type l -exec rm -f {} \; + find $1 -type l -exec rm -f {} + } setup_symlinks() { |