diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-07-16 05:28:13 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-07-16 05:28:13 +0000 |
commit | b70ced7eab19e15d0603e6f02e1098524b132407 (patch) | |
tree | e465439efe723411cc04e639c0a7477029ef345d | |
parent | ea2f9b7e7d87f781dbb9b4e0b9e982827c887195 (diff) | |
download | upstream-b70ced7eab19e15d0603e6f02e1098524b132407.tar.gz upstream-b70ced7eab19e15d0603e6f02e1098524b132407.tar.bz2 upstream-b70ced7eab19e15d0603e6f02e1098524b132407.zip |
kernel: fix dependencies for .config, use selections from oldconfig when running menuconfig
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7997 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Makefile | 1 | ||||
-rw-r--r-- | include/kernel-build.mk | 12 |
2 files changed, 6 insertions, 7 deletions
@@ -93,7 +93,6 @@ menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FO $< Config.in kernel_menuconfig: .config FORCE - -$(MAKE) target/linux-prepare $(NO_TRACE_MAKE) -C target/linux menuconfig diff --git a/include/kernel-build.mk b/include/kernel-build.mk index 4088422088..1df80d16f6 100644 --- a/include/kernel-build.mk +++ b/include/kernel-build.mk @@ -98,15 +98,15 @@ define BuildKernel $(call Kernel/Prepare) touch $$@ - $(STAMP_CONFIGURED): $(LINUX_DIR)/.prepared $(LINUX_CONFIG) + $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(LINUX_CONFIG) $(GENERIC_LINUX_CONFIG) $(call Kernel/Configure) touch $$@ - $(LINUX_DIR)/.modules: $(LINUX_DIR)/.configured $(LINUX_DIR)/.config FORCE + $(LINUX_DIR)/.modules: $(STAMP_CONFIGURED) $(LINUX_DIR)/.config FORCE $(call Kernel/CompileModules) touch $$@ - $(LINUX_DIR)/.image: $(LINUX_DIR)/.configured FORCE + $(LINUX_DIR)/.image: $(STAMP_CONFIGURED) FORCE $(call Kernel/CompileImage) touch $$@ @@ -169,11 +169,11 @@ endef $(eval $(call shexport,Target/Description)) download: $(DL_DIR)/$(LINUX_SOURCE) -prepare: $(LINUX_DIR)/.configured +prepare: $(STAMP_CONFIGURED) compile: $(LINUX_DIR)/.modules -menuconfig: $(LINUX_DIR)/.prepared FORCE - $(call Kernel/Configure) +menuconfig: $(STAMP_PREPARED) FORCE $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config + $(call Kernel/Configure) $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) menuconfig $(SCRIPT_DIR)/config.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG) |