diff options
author | Philip Prindeville <philipp@redfish-solutions.com> | 2021-03-19 15:09:45 -0600 |
---|---|---|
committer | Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> | 2021-03-24 23:47:34 +0000 |
commit | af22991e03cae55f96b06996df2ff16752cec5d5 (patch) | |
tree | b560cedc16543e766135ce1f694421c0c2077c77 | |
parent | 1bf2b3fe90347641c87ca754913a4857a387478c (diff) | |
download | upstream-af22991e03cae55f96b06996df2ff16752cec5d5.tar.gz upstream-af22991e03cae55f96b06996df2ff16752cec5d5.tar.bz2 upstream-af22991e03cae55f96b06996df2ff16752cec5d5.zip |
build: make sure asm gets built with -DPIC
Fixes issue openwrt/packages#14921, whereby inline ASM wasn't getting
built as PIC; look at gmp-6.2.1/mpn/x86/pentium/popcount.asm for
example:
ifdef(`PIC',`
...
for a routine that exists in both PIC and non-PIC versions.
Make sure that wherever $(FPIC) gets passed as a variable expansion
that it gets quoted where necessary (such as setting environment
variables in shell commands).
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
-rw-r--r-- | rules.mk | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -75,12 +75,12 @@ IS_PACKAGE_BUILD := $(if $(filter package/%,$(BUILD_SUBDIR)),1) OPTIMIZE_FOR_CPU=$(subst i386,i486,$(ARCH)) ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be powerpc )) - FPIC:=-fPIC + FPIC:=-DPIC -fPIC else - FPIC:=-fpic + FPIC:=-DPIC -fpic endif -HOST_FPIC:=-fPIC +HOST_FPIC:=-DPIC -fPIC ARCH_SUFFIX:=$(call qstrip,$(CONFIG_CPU_TYPE)) GCC_ARCH:= |