aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-25 16:59:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-25 16:59:19 +0000
commit965adec3bedfc4e64e88d217e10cd96fb6b55b0a (patch)
tree7f55ea57e47884656e0cec9cc2ff767eea4c58dd
parentb70d752456156b816961fdc43bb2892c0f0611c1 (diff)
downloadupstream-965adec3bedfc4e64e88d217e10cd96fb6b55b0a.tar.gz
upstream-965adec3bedfc4e64e88d217e10cd96fb6b55b0a.tar.bz2
upstream-965adec3bedfc4e64e88d217e10cd96fb6b55b0a.zip
add extra targets to improve make tracing output
SVN-Revision: 4078
-rw-r--r--openwrt/include/kernel-build.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/openwrt/include/kernel-build.mk b/openwrt/include/kernel-build.mk
index dfd4227447..706764db58 100644
--- a/openwrt/include/kernel-build.mk
+++ b/openwrt/include/kernel-build.mk
@@ -8,6 +8,7 @@ LINUX_SITE=http://www.us.kernel.org/pub/linux/kernel/v$(KERNEL) \
KERNEL_IDIR:=$(KERNEL_BUILD_DIR)/kernel-ipkg
KERNEL_IPKG:=$(KERNEL_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)_$(ARCH).ipk
+TARGETS += $(KERNEL_IPKG)
INSTALL_TARGETS += $(KERNEL_IPKG)
$(TARGETS): $(PACKAGE_DIR)
@@ -74,8 +75,12 @@ $(LINUX_DIR)/.modules_done:
$(MAKE) -C "$(LINUX_DIR)" CROSS_COMPILE="$(KERNEL_CROSS)" DEPMOD=true INSTALL_MOD_PATH=$(KERNEL_BUILD_DIR)/modules modules_install
touch $(LINUX_DIR)/.modules_done
+modules: $(LINUX_DIR)/.modules_done
+packages: $(TARGETS)
+
$(STAMP_DIR)/.linux-compile:
- @$(MAKE) $(LINUX_DIR)/.modules_done $(TARGETS) $(KERNEL_IPKG)
+ @$(MAKE) modules
+ @$(MAKE) packages
ln -sf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION) $(BUILD_DIR)/linux
touch $@