aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-08-30 10:24:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-08-30 10:24:11 +0000
commit7b8d2827f550a24518cd60029d228a301fa1e1e2 (patch)
tree742febf04ab8a5d98fa8909411ff03e78c5fb753
parent172e5eb67e8ffb5c548f1d4652d2cd18b9cc633c (diff)
downloadupstream-7b8d2827f550a24518cd60029d228a301fa1e1e2.tar.gz
upstream-7b8d2827f550a24518cd60029d228a301fa1e1e2.tar.bz2
upstream-7b8d2827f550a24518cd60029d228a301fa1e1e2.zip
only run trap error code in the configure template, if the configure script was not found
SVN-Revision: 4715
-rw-r--r--openwrt/include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 311ec35a9c..ce3c4b6a1b 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -263,7 +263,7 @@ endef
define Build/Configure/Default
@(cd $(PKG_BUILD_DIR)/$(3); \
- [ -x configure ] && \
+ [ -x configure ] && { \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -287,7 +287,7 @@ define Build/Configure/Default
--infodir=/usr/info \
$(DISABLE_NLS) \
$(1); \
- true; \
+ } || true; \
)
endef