aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-21 14:27:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-21 14:27:45 +0000
commit4d2f748fd2870eff5b76dcc4b5204e41e448d290 (patch)
tree229c45b597f8feb355f3ea035f7455697deab29c
parent3d2752f8b95e275ebfb28c905bb24175d24f4729 (diff)
downloadupstream-4d2f748fd2870eff5b76dcc4b5204e41e448d290.tar.gz
upstream-4d2f748fd2870eff5b76dcc4b5204e41e448d290.tar.bz2
upstream-4d2f748fd2870eff5b76dcc4b5204e41e448d290.zip
add submenu dependencies (used to hide the proprietary broadcom driver on anything except for brcm-2.4)
SVN-Revision: 4197
-rw-r--r--openwrt/include/package.mk5
-rw-r--r--openwrt/package/broadcom-wl/Makefile1
-rwxr-xr-xopenwrt/scripts/gen_menuconfig.pl7
3 files changed, 13 insertions, 0 deletions
diff --git a/openwrt/include/package.mk b/openwrt/include/package.mk
index 38fd93df73..757c8396ae 100644
--- a/openwrt/include/package.mk
+++ b/openwrt/include/package.mk
@@ -83,6 +83,7 @@ define Package/Default
DEFAULT:=
MENU:=
SUBMENU:=
+ SUBMENUDEP:=
TITLE:=
DESCRIPTION:=
endef
@@ -142,6 +143,10 @@ define BuildPackage
ifneq ($(SUBMENU),)
DUMPINFO += \
echo "Submenu: $(SUBMENU)";
+ ifneq ($(SUBMENUDEP),)
+ DUMPINFO += \
+ echo "Submenu-Depends: $(SUBMENUDEP)";
+ endif
endif
ifneq ($(DEFAULT),)
diff --git a/openwrt/package/broadcom-wl/Makefile b/openwrt/package/broadcom-wl/Makefile
index 961baac55a..e6f322f4c6 100644
--- a/openwrt/package/broadcom-wl/Makefile
+++ b/openwrt/package/broadcom-wl/Makefile
@@ -28,6 +28,7 @@ define Package/kmod-brcm-wl
DEPENDS:=@LINUX_2_4_BRCM
DEFAULT:=y
SUBMENU:=Proprietary BCM43xx WiFi driver
+ SUBMENUDEP:=@LINUX_2_4_BRCM
TITLE:=Kernel driver (normal version)
DESCRIPTION:=Proprietary Wireless driver for the Broadcom BCM43xx chipset
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE)
diff --git a/openwrt/scripts/gen_menuconfig.pl b/openwrt/scripts/gen_menuconfig.pl
index e62363e630..ddce86bfa1 100755
--- a/openwrt/scripts/gen_menuconfig.pl
+++ b/openwrt/scripts/gen_menuconfig.pl
@@ -13,6 +13,7 @@ my $makefile;
my $pkg;
my %category;
my $cur_menu;
+my $cur_menu_dep;
sub print_category($) {
my $cat = shift;
@@ -26,10 +27,15 @@ sub print_category($) {
if ($cur_menu ne $pkg->{submenu}) {
if ($cur_menu) {
print "endmenu\n";
+ $cur_menu_dep and do {
+ print "endif\n";
+ $cur_menu_dep = undef;
+ };
undef $cur_menu;
}
if ($pkg->{submenu}) {
$cur_menu = $pkg->{submenu};
+ $cur_menu_dep = $pkg->{submenudep} and print "if $cur_menu_dep\n";
print "menu \"$cur_menu\"\n";
}
}
@@ -84,6 +90,7 @@ while ($line = <>) {
$line =~ /^Title: \s*(.+)\s*$/ and $pkg->{title} = $1;
$line =~ /^Menu: \s*(.+)\s*$/ and $pkg->{menu} = $1;
$line =~ /^Submenu: \s*(.+)\s*$/ and $pkg->{submenu} = $1;
+ $line =~ /^Submenu-Depends: \s*(.+)\s*$/ and $pkg->{submenudep} = $1;
$line =~ /^Default: \s*(.+)\s*$/ and $pkg->{default} = $1;
$line =~ /^Depends: \s*(.+)\s*$/ and do {
my @dep = split /\s+/, $1;