diff options
author | Florian Fainelli <florian@openwrt.org> | 2007-07-18 14:11:44 +0000 |
---|---|---|
committer | Florian Fainelli <florian@openwrt.org> | 2007-07-18 14:11:44 +0000 |
commit | 36703bb8d81d0025deda417b834b6b27e67fb517 (patch) | |
tree | c927c5563b954208368c342786a0b1e2d676bc8c | |
parent | 8eb5db243c0d308baca41cfa4e5f1a46cf04ed0d (diff) | |
download | upstream-36703bb8d81d0025deda417b834b6b27e67fb517.tar.gz upstream-36703bb8d81d0025deda417b834b6b27e67fb517.tar.bz2 upstream-36703bb8d81d0025deda417b834b6b27e67fb517.zip |
Add a USES_TGZ config.in variable, so that RB1xx profiles can use it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8039 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 2 | ||||
-rwxr-xr-x | scripts/metadata.pl | 1 | ||||
-rw-r--r-- | target/Config.in | 3 | ||||
-rw-r--r-- | target/linux/adm5120-2.6/profiles/RB1xx.mk | 1 |
4 files changed, 6 insertions, 1 deletions
@@ -36,7 +36,7 @@ menu "Target Images" config TARGET_ROOTFS_TGZ bool "tgz" - default y if !USES_SQUASHFS && !USES_JFFS2 + default y if USES_TGZ depends !TARGET_ROOTFS_INITRAMFS help Build a compressed tar archive of the the root filesystem diff --git a/scripts/metadata.pl b/scripts/metadata.pl index 484d4205f4..313efe75db 100755 --- a/scripts/metadata.pl +++ b/scripts/metadata.pl @@ -253,6 +253,7 @@ sub target_config_features(@) { /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n"; /jffs2/ and $ret .= "\tselect USES_JFFS2\n"; /ext2/ and $ret .= "\tselect USES_EXT2\n"; + /tgz/ and $ret .= "\tselect USES_TGZ\n"; } return $ret; } diff --git a/target/Config.in b/target/Config.in index e506512726..627940eb2e 100644 --- a/target/Config.in +++ b/target/Config.in @@ -35,6 +35,9 @@ config USES_JFFS2 config USES_EXT2 bool +config USES_TGZ + bool + config PROFILE_KCONFIG bool diff --git a/target/linux/adm5120-2.6/profiles/RB1xx.mk b/target/linux/adm5120-2.6/profiles/RB1xx.mk index 9dd3de0973..3d61cedc85 100644 --- a/target/linux/adm5120-2.6/profiles/RB1xx.mk +++ b/target/linux/adm5120-2.6/profiles/RB1xx.mk @@ -8,6 +8,7 @@ define Profile/RouterBoard NAME:=RouterBoard RB1xx PACKAGES:=kmod-madwifi + FEATURES+=tgz endef define Profile/RouterBoard/Description |