diff options
author | Felix Fietkau <nbd@openwrt.org> | 2007-10-05 21:52:05 +0000 |
---|---|---|
committer | Felix Fietkau <nbd@openwrt.org> | 2007-10-05 21:52:05 +0000 |
commit | 21a246d5d6b0ff0b1c632d7700a31886c5f09b23 (patch) | |
tree | 31251b93d5d51e7ad886b67b9380ecca8144f603 | |
parent | e2e8d55dcceef88f4c6e366ee690e7ab4beed14b (diff) | |
download | upstream-21a246d5d6b0ff0b1c632d7700a31886c5f09b23.tar.gz upstream-21a246d5d6b0ff0b1c632d7700a31886c5f09b23.tar.bz2 upstream-21a246d5d6b0ff0b1c632d7700a31886c5f09b23.zip |
add option for cleaning all ipkg info before the image build
SVN-Revision: 9151
-rw-r--r-- | Config.in | 14 | ||||
-rw-r--r-- | package/Makefile | 1 |
2 files changed, 12 insertions, 3 deletions
@@ -80,14 +80,22 @@ menuconfig DEVEL select TOOLCHAINOPTS if !NATIVE_TOOLCHAIN config BROKEN - bool "Show broken platforms / packages" if DEVEL + bool + prompt "Show broken platforms / packages" if DEVEL default n config LOCALMIRROR - string "Local mirror for source packages" if DEVEL + string + prompt "Local mirror for source packages" if DEVEL menuconfig BUILDOPTS - bool "Build Options" if DEVEL + bool + prompt "Build Options" if DEVEL + +config CLEAN_IPKG + bool + prompt "Clean all ipkg files before building the rootfs" if BUILDOPTS + default n config AUTOREBUILD bool diff --git a/package/Makefile b/package/Makefile index aa059a7d23..1df4537dba 100644 --- a/package/Makefile +++ b/package/Makefile @@ -35,6 +35,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build @-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf @-find $(TARGET_DIR) -name .svn | $(XARGS) rm -rf @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f + $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg) $(curdir)/index: FORCE @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) |