aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-23 13:29:15 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-23 13:29:15 +0000
commit1ce3686fac1c9ceb08e0c37a9c2f25dc2edcd139 (patch)
treedd9569ec1631a486e393496079fd2c7c73b6e309
parentc2e15f935ad8e750f364942656da1577d9b4a89b (diff)
downloadupstream-1ce3686fac1c9ceb08e0c37a9c2f25dc2edcd139.tar.gz
upstream-1ce3686fac1c9ceb08e0c37a9c2f25dc2edcd139.tar.bz2
upstream-1ce3686fac1c9ceb08e0c37a9c2f25dc2edcd139.zip
standardize Makefile, change section from base to net
SVN-Revision: 4814
-rw-r--r--openwrt/package/pptp/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/openwrt/package/pptp/Makefile b/openwrt/package/pptp/Makefile
index b060c12a79..b32ab06275 100644
--- a/openwrt/package/pptp/Makefile
+++ b/openwrt/package/pptp/Makefile
@@ -21,20 +21,21 @@ PKG_CAT:=zcat
include $(INCLUDE_DIR)/package.mk
define Package/pptp
-SECTION:=base
-# CATEGORY:=FIXME
-TITLE:=PPTP (Point-to-Point Tunneling Protocol) client
-DESCRIPTION:=A Point-to-Point Tunneling Protocol Client
-URL:=http://pptpclient.sourceforge.net/
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=PPTP client
+ DESCRIPTION:=\
+ This package contains a PPTP (Point-to-Point Tunneling Protocol) client.
+ URL:=http://pptpclient.sourceforge.net/
endef
define Package/pptp/install
+ install -d -m0755 $(1)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
install -d -m0755 $(1)/etc/ppp
install -m0644 ./files/options.pptp $(1)/etc/ppp/
install -d -m0755 $(1)/lib/network
install -m0755 ./files/pptp.sh $(1)/lib/network/
- install -d -m0755 $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,pptp))