aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfs4/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'tools/squashfs4/.svn')
-rw-r--r--tools/squashfs4/.svn/entries65
-rw-r--r--tools/squashfs4/.svn/prop-base/Makefile.svn-base5
-rw-r--r--tools/squashfs4/.svn/text-base/Makefile.svn-base43
3 files changed, 113 insertions, 0 deletions
diff --git a/tools/squashfs4/.svn/entries b/tools/squashfs4/.svn/entries
new file mode 100644
index 0000000..1fd7a6c
--- /dev/null
+++ b/tools/squashfs4/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/squashfs4
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-03-07T17:32:29.455175Z
+35900
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+d8146e252429093c91fc603481fcf4c7
+2012-08-12T13:27:49.032927Z
+33148
+jow
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1121
+
diff --git a/tools/squashfs4/.svn/prop-base/Makefile.svn-base b/tools/squashfs4/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/tools/squashfs4/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/tools/squashfs4/.svn/text-base/Makefile.svn-base b/tools/squashfs4/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..b838b46
--- /dev/null
+++ b/tools/squashfs4/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs4
+PKG_VERSION:=4.2
+
+PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/squashfs
+PKG_MD5SUM:=1b7a781fb4cf8938842279bd3e8ee852
+PKG_CAT:=zcat
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfs$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ CC="$(HOSTCC)" \
+ XZ_SUPPORT=1 \
+ LZMA_XZ_SUPPORT=1 \
+ XATTR_SUPPORT= \
+ LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
+ EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
+ EXTRA_LDFLAGS="$(HOST_STATIC_LINKING)" \
+ mksquashfs unsquashfs
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+$(eval $(call HostBuild))