aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/.svn')
-rw-r--r--toolchain/gcc/.svn/entries145
-rw-r--r--toolchain/gcc/.svn/prop-base/Config.in.svn-base5
-rw-r--r--toolchain/gcc/.svn/text-base/Config.in.svn-base97
-rw-r--r--toolchain/gcc/.svn/text-base/Config.version.svn-base51
-rw-r--r--toolchain/gcc/.svn/text-base/common.mk.svn-base200
5 files changed, 498 insertions, 0 deletions
diff --git a/toolchain/gcc/.svn/entries b/toolchain/gcc/.svn/entries
new file mode 100644
index 0000000..eb10b57
--- /dev/null
+++ b/toolchain/gcc/.svn/entries
@@ -0,0 +1,145 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/gcc
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-26T16:39:54.476606Z
+35808
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+minimal
+dir
+
+patches
+dir
+
+final
+dir
+
+initial
+dir
+
+Config.version
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+f5fab1cb057c4af80006b494fa4cd6ed
+2013-02-26T14:31:24.515930Z
+35805
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1086
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+ce5aa50edb8e3313c919c27b3b2e125f
+2013-02-26T14:31:24.515930Z
+35805
+luka
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2259
+
+common.mk
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+b9eb2090ad0d9a7b76c30c9851c7f807
+2013-02-26T14:31:24.515930Z
+35805
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+5809
+
diff --git a/toolchain/gcc/.svn/prop-base/Config.in.svn-base b/toolchain/gcc/.svn/prop-base/Config.in.svn-base
new file mode 100644
index 0000000..abd5821
--- /dev/null
+++ b/toolchain/gcc/.svn/prop-base/Config.in.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 2
+LF
+END
diff --git a/toolchain/gcc/.svn/text-base/Config.in.svn-base b/toolchain/gcc/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..f83f83c
--- /dev/null
+++ b/toolchain/gcc/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,97 @@
+# Choose gcc version.
+
+choice
+ prompt "GCC compiler Version" if TOOLCHAINOPTS
+ default GCC_VERSION_4_4_7 if GCC_DEFAULT_VERSION_4_4_7
+ default GCC_VERSION_4_6_LINARO
+ help
+ Select the version of gcc you wish to use.
+
+ config GCC_VERSION_4_4_7
+ bool "gcc 4.4.7"
+ depends avr32
+
+ config GCC_VERSION_4_6_3
+ bool "gcc 4.6.3"
+
+ config GCC_VERSION_4_7_2
+ bool "gcc 4.7.2"
+
+ config GCC_VERSION_4_5_LINARO
+ bool "gcc 4.5.x with Linaro enhancements"
+
+ config GCC_VERSION_4_6_LINARO
+ bool "gcc 4.6.x with Linaro enhancements"
+
+ config GCC_VERSION_4_7_LINARO
+ bool "gcc 4.7.x with Linaro enhancements"
+
+ config GCC_VERSION_LLVM
+ bool "llvm-gcc 4.2"
+ depends BROKEN
+
+endchoice
+
+config GCC_USE_GRAPHITE
+ bool
+ prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
+ depends !GCC_VERSION_LLVM
+
+config GCC_USE_SYSTEM_PPL_CLOOG
+ bool
+ prompt "Use the system versions of PPL and CLooG"
+ depends GCC_USE_GRAPHITE
+ default n
+
+config EXTRA_GCC_CONFIG_OPTIONS
+ string
+ prompt "Additional gcc configure options" if TOOLCHAINOPTS
+ default ""
+ help
+ Any additional gcc options you may want to include....
+
+config SSP_SUPPORT
+ bool
+ prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
+ default n
+ help
+ Enable Stack-Smashing Protection support
+
+config TLS_SUPPORT
+ bool
+ prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
+ default n
+ help
+ Enable Thread-local storage support
+
+config SJLJ_EXCEPTIONS
+ bool
+ prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
+ default n
+ help
+ Use old setjump()/longjump() exceptions instead of the newer
+ frame unwinding exceptions handling routines. Warning: increases
+ code size and runtime memory usage.
+
+config INSTALL_LIBSTDCPP
+ bool
+ prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
+ default y if !USE_MUSL
+ help
+ Build/install c++ compiler and libstdc++?
+
+config INSTALL_LIBGCJ
+ bool
+ depends on !GCC_VERSION_LLVM
+ prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
+ default n
+ help
+ Build/install java compiler and GNU classpath ?
+
+
+config INSTALL_GFORTRAN
+ bool
+ prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
+ default n
+ help
+ Build/install GNU fortran compiler ?
diff --git a/toolchain/gcc/.svn/text-base/Config.version.svn-base b/toolchain/gcc/.svn/text-base/Config.version.svn-base
new file mode 100644
index 0000000..9c84363
--- /dev/null
+++ b/toolchain/gcc/.svn/text-base/Config.version.svn-base
@@ -0,0 +1,51 @@
+config GCC_DEFAULT_VERSION
+ bool
+
+config GCC_DEFAULT_VERSION_4_4_7
+ select GCC_DEFAULT_VERSION
+ default y if avr32
+ bool
+
+config GCC_DEFAULT_VERSION_4_6_LINARO
+ default y if !(GCC_DEFAULT_VERSION)
+ bool
+
+
+config GCC_VERSION
+ string
+ default "4.4.7" if GCC_VERSION_4_4_7
+ default "4.6.3" if GCC_VERSION_4_6_3
+ default "4.7.2" if GCC_VERSION_4_7_2
+ default "4.5-linaro" if GCC_VERSION_4_5_LINARO
+ default "4.6-linaro" if GCC_VERSION_4_6_LINARO
+ default "4.7-linaro" if GCC_VERSION_4_7_LINARO
+ default "llvm" if GCC_VERSION_LLVM
+ default "4.6-linaro"
+
+config GCC_VERSION_4_4
+ bool
+ default y if GCC_VERSION_4_4_7
+
+config GCC_VERSION_4_5
+ bool
+ default y if GCC_VERSION_4_5_LINARO
+
+config GCC_VERSION_4_6
+ bool
+ default y if (GCC_VERSION_4_6_3 || GCC_VERSION_4_6_LINARO)
+
+config GCC_VERSION_4_7
+ bool
+ default y if (GCC_VERSION_4_7_2 || GCC_VERSION_4_7_LINARO)
+
+if !TOOLCHAINOPTS
+
+ config GCC_VERSION_4_4_7
+ default y if GCC_DEFAULT_VERSION_4_4_7
+ bool
+
+ config GCC_VERSION_4_6_LINARO
+ default y if GCC_DEFAULT_VERSION_4_6_LINARO
+ bool
+
+endif
diff --git a/toolchain/gcc/.svn/text-base/common.mk.svn-base b/toolchain/gcc/.svn/text-base/common.mk.svn-base
new file mode 100644
index 0000000..973b0d6
--- /dev/null
+++ b/toolchain/gcc/.svn/text-base/common.mk.svn-base
@@ -0,0 +1,200 @@
+#
+# Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
+# Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
+# Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gcc
+GCC_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
+PKG_VERSION:=$(firstword $(subst +, ,$(GCC_VERSION)))
+GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+ifdef CONFIG_GCC_VERSION_LLVM
+ PKG_SOURCE_VERSION:=c98c494b72ff875884c0c7286be67f16f9f6d7ab
+ PKG_REV:=83504
+ GCC_DIR:=llvm-gcc-4.2-r$(PKG_REV)
+ PKG_VERSION:=4.2.1
+ PKG_SOURCE:=$(GCC_DIR).tar.gz
+ PKG_SOURCE_PROTO:=git
+ PKG_SOURCE_URL:=git://repo.or.cz/llvm-gcc-4.2.git
+ PKG_SOURCE_SUBDIR:=$(GCC_DIR)
+ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
+else
+ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
+ ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
+ PKG_REV:=4.5-2012.03
+ PKG_VERSION:=4.5.4
+ PKG_VERSION_MAJOR:=4.5
+ PKG_MD5SUM:=0c25f93e15e362e352c933e4649a7fc6
+ endif
+ ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
+ PKG_REV:=4.6-2012.12
+ PKG_VERSION:=4.6.4
+ PKG_VERSION_MAJOR:=4.6
+ PKG_MD5SUM:=6b6c6a4faa026edd1193cf6426309039
+ endif
+ ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
+ PKG_REV:=4.7-2012.12
+ PKG_VERSION:=4.7.3
+ PKG_VERSION_MAJOR:=4.7
+ PKG_MD5SUM:=247b15687358bc7958eeb91ab22637d1
+ endif
+ PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+ PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
+ GCC_DIR:=gcc-linaro-$(PKG_REV)
+ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
+else
+ PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
+ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ ifeq ($(PKG_VERSION),4.4.7)
+ PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
+ endif
+ ifeq ($(PKG_VERSION),4.6.3)
+ PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
+ endif
+ ifeq ($(PKG_VERSION),4.7.2)
+ PKG_MD5SUM:=cc308a0891e778cfda7a151ab8a6e762
+ endif
+endif
+endif
+
+PATCH_DIR=../patches/$(GCC_VERSION)
+
+BUGURL=https://dev.openwrt.org/
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+HOST_SOURCE_DIR:=$(HOST_BUILD_DIR)
+ifeq ($(GCC_VARIANT),minimal)
+ GCC_BUILD_DIR:=$(HOST_BUILD_DIR)-$(GCC_VARIANT)
+else
+ HOST_BUILD_DIR:=$(HOST_BUILD_DIR)-$(GCC_VARIANT)
+ GCC_BUILD_DIR:=$(HOST_BUILD_DIR)
+endif
+
+HOST_STAMP_PREPARED:=$(HOST_BUILD_DIR)/.prepared
+HOST_STAMP_BUILT:=$(GCC_BUILD_DIR)/.built
+HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
+HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
+
+SEP:=,
+TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)"
+
+export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+ export glibcxx_cv_c99_math_tr1=no
+endif
+
+GCC_CONFIGURE:= \
+ SHELL="$(BASH)" \
+ $(HOST_SOURCE_DIR)/configure \
+ --prefix=$(TOOLCHAIN_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --with-gnu-ld \
+ --enable-target-optspace \
+ --disable-libgomp \
+ --disable-libmudflap \
+ --disable-multilib \
+ --disable-nls \
+ $(GRAPHITE_CONFIGURE) \
+ --with-host-libstdcxx=-lstdc++ \
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
+ $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+ $(if $(CONFIG_sparc),--with-long-double-128) \
+
+ifeq ($(CONFIG_GCC_LLVM),)
+ GCC_BUILD_TARGET_LIBGCC:=y
+ GCC_CONFIGURE+= \
+ --with-gmp=$(TOPDIR)/staging_dir/host \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --disable-decimal-float
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
+endif
+
+ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
+ GCC_CONFIGURE+= \
+ --with-mpc=$(TOPDIR)/staging_dir/host
+endif
+
+ifneq ($(CONFIG_SSP_SUPPORT),)
+ GCC_CONFIGURE+= \
+ --enable-libssp
+else
+ GCC_CONFIGURE+= \
+ --disable-libssp
+endif
+
+ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
+ GCC_CONFIGURE+= \
+ --enable-biarch \
+ --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
+endif
+
+ifdef CONFIG_sparc
+ GCC_CONFIGURE+= --enable-targets=all
+endif
+
+ifeq ($(LIBC),uClibc)
+ GCC_CONFIGURE+= \
+ --disable-__cxa_atexit
+else
+ GCC_CONFIGURE+= \
+ --enable-__cxa_atexit
+endif
+
+ifneq ($(GCC_ARCH),)
+ GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
+endif
+
+GCC_MAKE:= \
+ export SHELL="$(BASH)"; \
+ $(MAKE) \
+ CFLAGS="$(HOST_CFLAGS)" \
+ CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
+ CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"
+
+define Host/Prepare
+ mkdir -p $(GCC_BUILD_DIR)
+endef
+
+define Host/Configure
+ (cd $(GCC_BUILD_DIR) && rm -f config.cache; \
+ $(GCC_CONFIGURE) \
+ );
+endef
+
+define Host/Clean
+ rm -rf \
+ $(STAGING_DIR_HOST)/stamp/.gcc_* \
+ $(STAGING_DIR_HOST)/stamp/.binutils_* \
+ $(GCC_BUILD_DIR) \
+ $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME) \
+ $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME) \
+ $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gc* \
+ $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-c*
+endef