aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'target/sdk/.svn')
-rw-r--r--target/sdk/.svn/entries99
-rw-r--r--target/sdk/.svn/prop-base/Config.in.svn-base5
-rw-r--r--target/sdk/.svn/prop-base/Makefile.svn-base5
-rw-r--r--target/sdk/.svn/text-base/Config.in.svn-base9
-rw-r--r--target/sdk/.svn/text-base/Makefile.svn-base74
5 files changed, 192 insertions, 0 deletions
diff --git a/target/sdk/.svn/entries b/target/sdk/.svn/entries
new file mode 100644
index 0000000..5152efe
--- /dev/null
+++ b/target/sdk/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/sdk
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-11-01T07:15:49.791201Z
+34051
+cshore
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:06.000000Z
+8f8fe35ef851bc3fc4091c0fbf6d933d
+2009-12-18T18:55:03.824590Z
+18837
+nico
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+273
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:06.000000Z
+57a4971300518f7689d8592ef1f68930
+2012-11-01T07:15:49.791201Z
+34051
+cshore
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2362
+
diff --git a/target/sdk/.svn/prop-base/Config.in.svn-base b/target/sdk/.svn/prop-base/Config.in.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/sdk/.svn/prop-base/Config.in.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/sdk/.svn/prop-base/Makefile.svn-base b/target/sdk/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/sdk/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/sdk/.svn/text-base/Config.in.svn-base b/target/sdk/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..c8106d2
--- /dev/null
+++ b/target/sdk/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,9 @@
+config SDK
+ bool "Build the OpenWrt SDK"
+ depends !EXTERNAL_TOOLCHAIN
+ help
+ This is essentially a stripped-down version of the buildroot
+ with a precompiled toolchain. It can be used to develop and
+ test packages for OpenWrt before including them in the buildroot
+
+
diff --git a/target/sdk/.svn/text-base/Makefile.svn-base b/target/sdk/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..d6c42b0
--- /dev/null
+++ b/target/sdk/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,74 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
+
+override MAKEFLAGS=
+
+PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
+PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
+
+SDK_NAME:=OpenWrt-SDK-$(BOARD)-for-$(PKG_OS)-$(PKG_CPU)-gcc-$(GCCV)_$(LIBC)-$(LIBCV)
+SDK_BUILD_DIR:=$(BUILD_DIR)/$(SDK_NAME)
+EXCLUDE_DIRS:=*/ccache \
+ */stamp \
+ */stampfiles \
+ */man \
+ */info
+
+SVN_PACKAGE_URL=$(shell svn info ../../package | awk '/^URL:/ { print $$2; }')
+
+all: compile
+
+$(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
+ mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
+ $(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
+ $(TAR) -cf - -C $(TOPDIR) \
+ $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \
+ --exclude="staging_dir/$(ARCH)" \
+ staging_dir/host staging_dir/target-$(ARCH)$(ARCH_SUFFIX)_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi) \
+ staging_dir/toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi) | \
+ $(TAR) -xf - -C $(SDK_BUILD_DIR)
+ mkdir -p $(SDK_BUILD_DIR)/target/linux
+ $(CP) $(GENERIC_PLATFORM_DIR) $(PLATFORM_DIR) $(SDK_BUILD_DIR)/target/linux/
+ rm -rf \
+ $(SDK_BUILD_DIR)/target/linux/*/files \
+ $(SDK_BUILD_DIR)/target/linux/*/patches
+ $(CP) -L \
+ $(TOPDIR)/LICENSE \
+ $(TOPDIR)/rules.mk \
+ $(TOPDIR)/.config \
+ ./files/Config.in \
+ ./files/Makefile \
+ ./files/README.SDK \
+ $(SDK_BUILD_DIR)/
+ $(CP) \
+ ./files/package/rules.mk \
+ $(TOPDIR)/package/Makefile \
+ $(SDK_BUILD_DIR)/package/
+ $(if $(SVN_PACKAGE_URL),echo "src-svn trunk $(SVN_PACKAGE_URL)" \
+ > $(SDK_BUILD_DIR)/feeds.conf.default,\
+ -rm -f $(SDK_BUILD_DIR)/feeds.conf.default)
+ cat $(TOPDIR)/feeds.conf.default \
+ >> $(SDK_BUILD_DIR)/feeds.conf.default
+ $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(SDK_BUILD_DIR)/include/version.mk
+ find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
+ find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
+ find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf
+ (cd $(BUILD_DIR); \
+ tar cfj $@ $(SDK_NAME); \
+ )
+
+download:
+prepare:
+compile: $(BIN_DIR)/$(SDK_NAME).tar.bz2
+install: compile
+
+clean:
+ rm -rf $(SDK_BUILD_DIR) $(BIN_DIR)/$(SDK_NAME).tar.bz2