aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/xburst/image')
-rw-r--r--target/linux/xburst/image/.svn/entries96
-rw-r--r--target/linux/xburst/image/.svn/text-base/Makefile.svn-base46
-rw-r--r--target/linux/xburst/image/.svn/text-base/ubinize.cfg.svn-base14
-rw-r--r--target/linux/xburst/image/Makefile46
-rw-r--r--target/linux/xburst/image/ubinize.cfg14
5 files changed, 216 insertions, 0 deletions
diff --git a/target/linux/xburst/image/.svn/entries b/target/linux/xburst/image/.svn/entries
new file mode 100644
index 0000000..51a15a9
--- /dev/null
+++ b/target/linux/xburst/image/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/xburst/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2010-05-12T23:12:41.532808Z
+21438
+lars
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+ubinize.cfg
+file
+
+
+
+
+2013-03-17T12:12:37.000000Z
+a9198c8b3f8d6c7646c8264176d6c219
+2010-01-11T04:44:45.989662Z
+19098
+lars
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+254
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:37.000000Z
+c57a4bfcd81eb85d3829846793b20fe2
+2010-05-12T23:12:41.532808Z
+21438
+lars
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1131
+
diff --git a/target/linux/xburst/image/.svn/text-base/Makefile.svn-base b/target/linux/xburst/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..9c03b38
--- /dev/null
+++ b/target/linux/xburst/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=256k 512k
+
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBIFS_OPTS = -m 4096 -e 516096 -c 4095
+UBINIZE_OPTS = -m 4096 -p 512KiB
+else
+UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+endif
+
+UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+
+define kernel_entry
+0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
+endef
+
+
+define MkImageGzip
+ gzip -9 -c $(1) > $(1).gz
+ mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
+ -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(1).gz $(2)
+endef
+
+define Image/BuildKernel
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/xburst/image/.svn/text-base/ubinize.cfg.svn-base b/target/linux/xburst/image/.svn/text-base/ubinize.cfg.svn-base
new file mode 100644
index 0000000..49d55b9
--- /dev/null
+++ b/target/linux/xburst/image/.svn/text-base/ubinize.cfg.svn-base
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
new file mode 100644
index 0000000..9c03b38
--- /dev/null
+++ b/target/linux/xburst/image/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=256k 512k
+
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBIFS_OPTS = -m 4096 -e 516096 -c 4095
+UBINIZE_OPTS = -m 4096 -p 512KiB
+else
+UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+endif
+
+UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+
+define kernel_entry
+0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
+endef
+
+
+define MkImageGzip
+ gzip -9 -c $(1) > $(1).gz
+ mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
+ -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(1).gz $(2)
+endef
+
+define Image/BuildKernel
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/xburst/image/ubinize.cfg b/target/linux/xburst/image/ubinize.cfg
new file mode 100644
index 0000000..49d55b9
--- /dev/null
+++ b/target/linux/xburst/image/ubinize.cfg
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+